Really struggling with my dome control on my new build. Dominator, Holley billet solenoid block (bullet valves one), CO2 regulated to various areas for testing, single TiAl V60D wastegate. Bottle regulator to solenoid distance 6'. Solenoids to dome distance 1'.

I initially setup PID the solenoids using the strip chart feature and boost by time chart. I tried various different combinations of PID and came up with several configurations that provided very good results and followed the commanded curve great. However, if I ran the tests back to back, eventually I would get a spike. Sometimes I'd get 5 or 8 perfect runs in a row then 9th run would spike and subsequent ones would spike. I tried more and more PID combinations, and stayed lazy on P to try to lower the risk of a spike. We got the car on the dyno and started on wastegate alone (2 psi spring) and tuned the car. Once we tried CO2 (Boost By RPM in this case) we had the same issues, and the spikes were causing nearly 100 RWHP jumps on the dyno. Most often occurring when the ECU commands a vent.

Troubleshooting:
I've tried multiple different rate limiters, no success. I've removed the solenoids from the billet block and swapped their locations, no success. Ive tried from 40-110 psi regulated pressure, no success. Ive built a little tank to simulate more wastegate dome volume and plumbed it into the system, no success. I've tried the other solenoids in the drop down, including custom, no success. It fails in Strip Charts and on dyno, with it acting more severe on dyno. I've leak checked and wire checked

Areas I'm confused on:
1. The spike happens after the fill solenoid closes and during the vent solenoid opening, shown in the first attachment. Orange is fill, pink is vent, blue is the dome. This is a 300 FPS datalog zoomed in on the spike.
Click image for larger version. 

Name:	20201106_210330.jpg 
Views:	8 
Size:	74.7 KB 
ID:	10847
2. The spikes don't happen on an upward ramp, they happen on a vent command. Which isn't a big deal on a Strip Chart, but mid dyno pull if it needs to do some venting due to pressure on the bottom side of the wastegate, etc., a spike is likely.
Click image for larger version. 

Name:	20201029_195442.jpg 
Views:	4 
Size:	71.8 KB 
ID:	10848
3. During a flat commanded boost, say 20 psi for 10 seconds, there continues to be fill DC for all 10 seconds. This doesn't make sense to me, I would think it would fill and the fill DC would drop once target was reached. Looking at YouTube videos, I see others also have fill DC in the same scenarios. I would think if there was any fill DC without vent for 10 seconds, the dome would overshoot all the way to regulated bottle pressure.

4. Dome sensor noise. I ran datalogs/Strip Charts one a -1 to 1 scale to look at sensor noise. Oil pressure and Fuel pressure (both fixed Holley inputs, and on Holley harness) are super smooth with little variation. Coolant pressure, crankcase pressure and dome pressure (all sensors I added) have much larger swings. To test, I rewired the dome outside of the car away from other wires and created a ECU ground output specifically for it, no improvement. Are the OP & FP inputs on the ECU filtered or signal conditioned? Every transducer is the same Holley 0-100 SS one. Teal & Pink are OP & FP.
Click image for larger version. 

Name:	Screenshot_20201110-102610_Gallery.jpg 
Views:	3 
Size:	33.1 KB 
ID:	10849
I've ordered some standard square Mac valves and intend to try them next.