Results 1 to 3 of 3

Thread: No cranking fuel pressure & no RPM signal

  1. #1

    Default No cranking fuel pressure & no RPM signal

    Hey guys. Just finished installing the Avenger EFI system. The install went smoothly, but I'm checking to see if we've got everything installed properly as we're showing low/0 fuel PSI and no RPM signal.

    We've got the yellow loose wire connected to the - terminal on an MSD Blaster II coil with a traditional MSD vacuum advance ready-to-run distributor. No MSD box. Showing Stl on the ignition dispaly.

    Also, we're only showing 10 or so PSI during fuel pump prime, which goes to 0 after the prime and does not increase when cranking. Obviously, we're a no-start so far. Thoughts? Thanks!

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,709

    Default

    "STL" indicates stall, meaning no RPM input is detected.

    That MSD Ready-To-Run distributor has four wires:
    Green or Gray - tachometer connection.
    Red - to coil positive terminal. (Keyed 12 volts should also be connected here.)
    Orange - to coil negative terminal. (Avenger loose yellow wire should also be connected here; no timing control & no MSD box!)
    Black - to engine ground.

    During the initial engine calibration (using the hand-held controller), did you select no ECU controlled timing?
    FYI: Your engine will run much better using the late model, small-cap GM HEI computer controlled distributor,
    due to the optimum timing curve already programmed in the ECU. Computer controlled timing is a significant aspect of EFI.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  3. #3

    Default

    Thanks Danny. Thanks to Holley's Tech Support team, I think we're tracking this one down. We may just have a low voltage situation. The car had been sitting a while and we think we're not making enough juice at idle to make spark, hence no RPM signal. We'll be back at it in a few, and we'll post the results here. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us