Hey all, I recently purchased a Holley wideband O2 #26-626. Instructions state that it can be used stand-alone and has an an analog output which is great for tuning purposes. Here's my problem, I like to test my gauges before I go through the hassle of hard-wiring them in. On my previous widebands, I would mock them up with a battery, verify that the needle sweeps (or whatever it is supposed to do upon startup), verify that the heater circuit is working(either by test light or via physical attributes i.e. O2 sensor gets warm to touch), and verify that it shows at least 18:1 when not in the exhaust and reading fresh air.

The problem is I do not see or feel the heater circuit working at all, and the gauge is not reading anything. Upon power up the gauge needle sweeps, then returns to 8:1 and stays there. I have attached a ground wire from the Negative terminal and wrapped around the sensor just in case it needed ground, no luck. My other widebands did not require me to ground the sensor but i thought I'd start there.

This is the 3rd Holley wideband product I have tried. The first 2 did NOT have the analog output, but those two would not heat up either, unless the TPS wire was hooked to ground, AFTER the gauge powered up. Weird I know, I tried it repeatedly with both those gauges, and the ONLY time the gauge would read is if I grounded out the green TPS wire AFTER the gauge had been powered up. According to the instructions on the previous widebands the GREEN TPS wire is only for utilizing the gauge warning light for a preset warning, and NOT required for gauge functioning.

I would really like to get this gauge working as it matches my other gauge that I use for tuning purposes which is fuel pressure. I use my gauges standalone style and power them either off a cigarette lighter or a Noco Jump starter. I made a little plexiglass stand that the gauge mounts attach to, making for a clean looking portable data display setup. I have previously used Daytona Sensors, AEM, Pertronix, PLX, and Innovate widebands, this way and Holley is the first one to not work. I like how simple the Holley gauge is i.e. no control boxes to deal with, and it matches my fuel pressure gauge. But if it will not work for my purposes then I guess it's back to the drawing board.

I appreciate any help and/or feedback, hopefully a Holley tech will chime in.