Results 1 to 6 of 6

Thread: Did I just fry my Terminator?

  1. #1

    Default Did I just fry my Terminator?

    So in the process of swapping things onto the new Ford 426W build, I'm wiring up the rear relay to the fuel pump.

    Standard procedure, key off, unhook battery negative post for main power, I suddenly hear the pump fire up and see the handheld in the dash fire up. So I scramble to unhook the Terminator negative.

    Several hours later I finish the wiring and new fuse block. Pressure comes right up to 43, acts like no spark, not even a fizzle.

    About 10s of cranking it coughs and tries to light, feather the gas and about 50% it finally fires up, but is popping and not wanting to stay steady on idle and keeps oscillate-hunting idle, steadily going worse and worse. This was from a rock steady tune before I started the wiring.

    As I'm down at the shop I want to get it home before she quits completely, so I jump in before it can die and take off. From dead stop she acts like she's bogged down with fuel or weak spark, which the handheld was showing very rich, and bogging on takeoff. Once above 2K she evened out and seemed to drive fine. Get home and start checking voltages.

    TFI module on the distributor shows +/- 5% of factory spec (Motorcraft module, Thanks Danny).
    MSD Blaster coil shows +/- 8% on primary, +/- 2% on secondary per MSD's specifications.
    Cap /rotor look fine

    Checking a new spark plug to intake ground has a very mild, slow, yellow spark that is barely heard above starter.

    So did I just fry my ignition circuit in the Terminator? I have no idea where the system backfeed was when I pulled the main terminal.

    Checking everything else in the system seems fine, handheld is fine, boots fine, all the menus are fine.
    Last edited by narmalee; 12-24-2019 at 02:27 PM.

  2. #2
    Join Date
    Nov 2014
    Location
    Ont. Canada
    Posts
    1,557

    Default

    Could it be a corrupt Global File or even the ECU firmware.

  3. #3
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    25,073

    Default

    Also, try completely disconnecting the battery for 20 minutes. This "resets" some unusual ECU issues.
    http://forums.holley.com/showthread....2193#post72193 (EFI Software/ECU Firmware Problems)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS T/W 11R 205 heads, 232°-244° duration/.623" lift/114° LSA camshaft, 12:1 C/R, TFS R-Series FTI ported intake, BBK 80mm T/B, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 200A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, -6AN fuel system plumbing, Walbro 255 LPH pump, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/3000 RPM converter, B&M Hammer shifter, FPP aluminum driveshaft, FPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 M/T Street Comp tires.

  4. #4

    Default

    Quote Originally Posted by Danny Cabral View Post
    Also, try completely disconnecting the battery for 20 minutes. This "resets" some unusual ECU issues.
    http://forums.holley.com/showthread....2193#post72193 (EFI Software/ECU Firmware Problems)
    I'm trying this now.
    Isn't the coil square wave from the Terminator supposed to be 5V? I haven't checked that yet, that's next on the list.

    Quote Originally Posted by 81 TransAm View Post
    Could it be a corrupt Global File or even the ECU firmware.
    I tried resetting the file, but I haven't tried a full reboot of firmware, going to be a last resort on that, I'm going to see what the output from the Terminator is tomorrow, having Christmas dinner tonight, so that's not happening right now.

    If the Terminator voltage is good, then I'm going to try swapping over to an MSD box and see if it'll fire that way, and just ignore the ECU for timing, at least try to pin down what's wrong. I was really hoping it was a fried TFI module, something easy, but apparently no luck there.
    Thanks very much for the quick reply guys, I appreciate it being Christmas Eve & all.
    I had planned to take the car up to the programmer this weekend and some dyno time, but looks like that is shot all to hell.

    OK, it's dark outside. I left battery unplugged from Terminator power harness for two hours, still no start, but I have blue strong spark from plug to intake now. Still totally unresponsive as far as trying to start, just crank crank crank. No spit, sputter or cough. I'll pull plugs and see what develops in the morning. Maybe plugs are fouled. If not, then I guess a hard restore is in order of Global Files/firmware.

    What a weird set of issues. I seem to have found the culprit. After replacing the TFM, cleaning the plugs, blowing the cylinders out to make sure any gas fumes were out, I tried again.

    Dead as a door knob. Using carb cleaner with TB unplugged I have a strong purple spark now, yet the engine absolutely refuses to make a peep, I even advanced the distributor 20° to make up for the ECU not advancing the spark (if that were the case, I'm trying all options here) yet nothing, not even a pop.

    So I take to the forums, investigating the keywords: backfeed, negative wire, messed up module. Well long story short, over on YellowBullet I found a post about someone with a 8 series MSD and carb having almost the exact same issue.

    Plug wires? Are you kidding me? How the heck can plug wires have anything to do...OHHHHHHHH.
    Plug wires ARE tied into direct +12V sources at both distributor and coil.
    This also involved same 10.5 Copper Spiro-wires that I run as well.
    Oh, this is starting to make sense now, as the Terminator is almost completely isolated from the rest of the electrical system, except the coil and distributor, BOTH have direct paths to +12V hot and ground in the same area.

    I break a meter out, wire #1 is about 70 Ohms, wire #2 nothing. YAY!!!!
    So I pop a plug in the end of it and ground it to intake and jump the starter solenoid. Sure enough, super weak thin/yellow spark after a few seconds of cranking.

    All told, there are 5 plug wires burnt up, but the ECU seems to be fine. Talk about a weird problem, this won't happen with carbon core wires, there isn't enough voltage to travel with just +12V. +12V however, WILL travel on 30 AWG copper wire just fine for a few seconds...oops.

    So there you have it folks, one of the weirdest electrical issues I've come across, even as an electrician or mechanic. Tomorrow, I'll go to NAPA and get a roll of wire and make some temp wires till I get a roll of MSD wire in.

    Hope everyone had a Merry Christmas! I know mine was pretty crummy thinking I had fried the Terminator. I've never been so happy to fry a set of plug wires before, LOL!

  5. #5

    Default

    Great info! Back in 1989, I bought a High Dollar set of Anodized Red Braided Steel Plug wires. I don't think I got a year outta them.

  6. #6

    Default

    LOL! I've been using the carbon core OEM replacements just fine for the last couple months, who knew. BUT the output coil part of the ECU was fried. It's putting out about 1/3 of the voltage it should be, but that really doesn't matter now that I'm using the digital output to the MSD box now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us