Results 1 to 3 of 3

Thread: Intermittent Sensor Ground

  1. #1

    Default Intermittent Sensor Ground

    I've attached a datalog of the car idling while I was under the hood moving the wires on the Holley harness around. The engine died when I lifted the Fuel Pressure connector @ 32.234 seconds, though pushing the injector connector up & down caused the first glitch at 18.412 seconds. What I've learned is that the glitch can be too fast for it to be recorded on all the sensors due to the relatively slow sampling rate (30 FPS). In the event at the end that killed the engine, it can be seen that most every sensor is affected. TPS jumps, oil pressure spikes, MAP goes above atmospheric and both CTS & MAT sensors dip. Note fuel pressure reading isn't affected, since I inject just the sensor voltage from my electronic FP gauge into the connector on the Holley harness.

    I believe the issue is due to the location in the harness where all the sensor grounds are spliced together to return to the ECU. Does this seem reasonable? Does anybody know where this location is? I need to get in there tomorrow and try to fix this issue, it's preventing me from driving the car.
    HEFI Log 20191102-170559.zip

  2. #2

    Default

    As a follow up, this morning I tried to do a TPS Autoset before further analysis and it wouldn't even let me do that. I then exposed the splice and bent the heat-shrink over the splice until it let me set the TPS. Then I started the car and bent the splice, and the car died. Problem confirmed. I carefully cut the heat shrink away from the splice and proceeded to tweak the wires, one broke off easily. I confirmed with a multimeter that the wire in question was connected to ground, the rest of the splice was 10-15K Ohm (essentially open.) I soldered the ground wire to the splice metal and re-taped the area with three layers. Car runs as normal again, whew. Now to get an oscilloscope and see the difference in signals between pin A28 and the tach wire from my ignition box to see if I can get my Digital Dash tach accurate again. I'll report my results in the other thread (LINK).

  3. #3

    Default

    BTW, I'm not blaming Holley for this issue, I had a rather tight stretch from the MAP sensor that's mounted to the firewall and the junction where all the other sensors branch off the harness. Since the MAP is stationary, I'm sure the torquing over of the engine stretched the sensor wires to the point of pulling the one wire out of the splice. I carefully re-routed the sensor pigtails to the other side of the fuel rail (closer to the MAP sensor) such that there's little/no stress on the wires.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us