Results 1 to 7 of 7

Thread: New Install on BBC - Starts sometimes stays running.

  1. #1

    Post New Install on BBC - Starts sometimes stays running.

    Good day everyone. Old guy (70) looking to relive my youth.

    I have taken on a project (Chevy 1966 C10 short-bed fleet side. Had an 1968 L78 396ci from '68 Chevelle SS rebuilt to stuff underhood along with rebuilt TH400 trans and 3:73 gears. Originally had a new Holley Ultra double pumper (650cfm) installed, but could not get it dialed in. So I returned it and bought the MSD Atomic. Pretty straight forward on install, and as promised (if ya follow the directions) it started up on first try. But the hard part isn't installing it's tweaking the system (and that's where I'm struggling). The distributor and timing I had done at a shop by Master Mechanic. So I'm looking for some input numbers to get a somewhat decent base to start from. I don't have much knowledge on the Atomic TBI or any fuel injection system for that matter. I have read about half of the threads on this forum, so naturally I now have mental confusion. The engine idles rough/drops out and stalls- backfires through exhaust or TB and doesn't seem to have a lot of power on high end. it does run better at higher RPM. But I haven't been pushed back in my seat yet.

    Shown below is the Engine data and current handheld input data. Engine 396 bored +.030" - Comp Cam #11-600-8, LSA 107°, @ 0.50" - Intake 227° - Exhaust 241°, Edelbrock Performance RPM dual-plane intake with 1" spacer plate- compression was lowered on rebuild from 11.0-1 to 10.5-1- Hedman 2 1/2" full length headers no X-pipe, Flowmaster muffler short exhaust out in front of rear tires. WBO2 sensor is in left hand collector box. Engine wasn't dynoed so no idea of HP or torque. But I believe there's plenty of each. Ignition system is all new up to date MSD with phased rotor.

    Initial settings:
    396 ci
    cylinders- 8
    cam- performance
    fuel pump- non-PWM (not in tank) with regulator and return line.
    air pump- NO
    idle target- 850
    rev limit- 6500
    timing- enabled

    Advance settings:
    AF targets- idle-14.0 cruise-14.0 WOT-12.8
    Nitro- off
    Boost- 10.0
    Pump squirt-25%
    Power Valve- 15%
    Nitro- Disabled

    Timing:
    Idle RPM-950
    Total RPM- 2200
    Idle advance- 12.0
    Total advance- 30.0
    Vacuum advance- 10.0
    Vacuum type- un-ported
    Nitros rtn- off
    Boost rtn- 0
    Fuel pressure- 43
    IAC neutral- 0
    IAC in gear- 0

    So there ya have it. Any and all suggestions will be read and hopefully lead me to a good running engine. I'm Looking for PERFORMANCE not MPG. Thanks in advance.

  2. #2
    Join Date
    Sep 2017
    Posts
    5

    Default

    Hi Frank66C10. How is your truck running? With luck all issues are already sorted As a bit of time has gone by. I see not a lot of response to your problem so wanted to let you know at least some people still reading this forum. Let me say that I'm not running timing control and may never get that far due to availability of parts, but I'm interested and have spent a lot of time reading other people’s posts. Should also say my engine running good without it, but at first it was not as good as it should have been which I initially thought was power valve or pump squirt settings. After a few drives I pulled the plugs to see what they could tell me and one was a bit fouled others all nice - replaced that And then it was everything I had hoped. So it is worth going over the simple stuff. That said I see most people on here say that backfiring etc., is timing related. Did you try running the Atomic without the timing control to confirm how it would go as a baseline. (Sorry for the simple answers.)

    I also see a lot of debate at to ported in ported and idle target RPM above or below timing idle target. It would not be hard to swap these and swap them back to see if you get an improvement. Pretty sure you would've thought of all of this, but wanted to let you know someone is out there.

  3. #3

    Default

    It looks the the cam is about at the threshold for using the Atomic. I expect this truck is going to idle rough with low idle vacuum. Of course you would select "Performance" cam during the setup. I'm not sure why you selected "un-ported" on the vacuum advance. That's going to bump up your initial timing (if I understand the Atomic programming). I'd use Ported timing so it doesn't come on until the throttle is opened some.

  4. #4

    Default

    Thanks for the reply PRN551. Truck is still not running properly. I've got it to start and Idle (1000 RPM) and go down the highway, but it still stumbles when RPM goes down and backfires out either side of the exhaust. So I'm still trying to find the right parameters to go with through the handheld unit. I'm going to start over and reinstall the complete ignition system including rephasing the distributor. But that will be after I get the TH400 rebuilt and armored next week (gotta have it ready for when engine is at full potential), LOL. It's my hobby now, but I'd rather remember the good times and not the bad. If my next go round of tweaking doesn't work out, I'll probably go back to old school distributor and disable the timing. I've also read the majority posts in forum, and from what I've read and my own experience, MSD Atomic is not the way to go. I'll repost in a few weeks on the results.

  5. #5

    Default

    I just got mine setup this weekend (still have to adjust/solve my fuel high pressure issue) and the Atomic is really great. My truck never ran as good. I'm very impressed. No tip-in hesitation, good idle (for my cam), A/F ratios staying where they should be.

    I would not give up on it so fast. When I went to the Timing Control setup I did have some issues getting the rotor phasing correct. But once that got adjusted, the engine just runs great.

  6. #6

    Default

    Thanks for the reply Countrybumkin. Your right on the cam & idle, and I didn't expect a smooth running built 396. But I did buy the complete MSD engine management system with the Atomic to maximize the engines potential. Ya know, money in - horsepower/torque out. I've tried both ported/unported vacuum from the various suggestions shown in this forum. At present it's on ported. It ran it's best on regular MSD distributor. At the present time, I'm moving onto rebuilding the transmission and then refreshing the 3.73 rear adding posi. Then I'll get back to the engine. I'll post how the tweaking of the MSD turns out.

    Thanks again Countrybumkin. I'm pleased to hear you got your issues worked out (with a few small tweaks to go) and your vehicle has put a smile on your face. So you've given me some hope. When the mechanicals are done in a few weeks, I'm gonna get back at the engine. I'll update ya.

  7. #7
    Join Date
    Sep 2017
    Posts
    5

    Default

    Hi Frank. Looking forward to finding out how your truck runs with the new upgrades. Also, good to know Countrybumkin is having success and is happy.

    Reading the forum has become my hobby as I don’t have many chances to drive my car at the moment. I don’t really have any issues to solve right now, but it makes me happy that most people seem to get problems sorted out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us