Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: Terminator X no start/backfire through intake.

  1. #21

    Default

    That was a good read, thank you. A friend let me borrow a set of good Bosch LS2 33 lb injectors to test. I put the correct injector data and I still have the same problem. Thing starts up & stalls before the starter stops. Could it be losing cam sync? With these injectors, I tried using waste-spark ignition and it did not start at all.

  2. #22
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,922

    Default

    See post #4 above.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  3. #23

    Default

    I was emailing back & forth with Holley tech. I sent them my Global File and datalog and I never received anything back. The person kept telling me my MAP sensor wasn't right, but I know it is. I'll try again. Thank you.

  4. #24

    Default

    What do you mean by "MAP sensor is not right?" PM me, I'll give you my email address.
    IG @projectgattago

  5. #25
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,922

    Default

    Maybe they think it doesn't start because the MAP kPa is measuring at the wrong place on the Base Fuel & Timing Tables.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  6. #26

    Default

    "If you're using the base calibration from the handheld, it may be looking for MAP pressure on the internal MAP sensor, not the sensor you 've plugged in unless you've it changed in the Terminator X software on a PC."
    Copied from email. The next email he tells me that the 2.5 bar is the default MAP sensor and I need to choose which one I have. I already told him that I've tripled checked and I have it selected correctly. 3rd email he tells me my MAP sensor may be bad and to unplug it and see what happens and also connect the internal MAP sensor. I emailed back that doing all of that does not seem to change anything. I included my Global File and datalog, but never received a response.

    I believe it was on this forum I found pictures of the fuel and ignition tables of a good running turbo 5.3L. This may have been dumb, stupid or dangerous for my engine, but I inserted all that data into my Global File and still never made a difference. I feel like I'm losing cam sync, but the Holley tech told me if I have an RPM reading, then the crank, cam sync is good. So I don't know. I've wired up a few different EFI systems and didn't have a problem, so I'm not a complete idiot.

  7. #27

    Default

    Are you looking at the LEDs? They're very helpful to see if you are getting cam & crank signals. Andrew
    IG @projectgattago

  8. #28
    Join Date
    May 2014
    Location
    Bostwick, GA
    Posts
    176

    Question

    Quote Originally Posted by Keystonespeed88 View Post
    Thing starts up & stalls before the starter stops.
    A dumb question. Are you sure the keyed power is on BOTH the start & run terminals, on the key switch? Yep, I've done that more than one time.
    Injector Inspector
    USAF 1960-1964
    Drag racing since 1955

  9. #29

    Default

    Quote Originally Posted by andrewb70 View Post
    Are you looking at the LEDs? They're very helpful to see if you are getting cam & crank signals. Andrew
    I believe both #6 and #7 leds have been red. Which makes no sense because holley tech support says if i have rpm then my crank signal is good

  10. #30

    Default

    Quote Originally Posted by Chuck L. View Post
    A dumb question. Are you sure the keyed power is on BOTH the start & run terminals, on the key switch? Yep, I've done that more than one time.
    The starter is wired to a push button.

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us