Hi guys. I'm fairly certain that one of my Bosch WBO2 sensors went bad a few weeks ago. Since then I've had the car out twice and it's running OK, using just the left side WBO2. I plan to order a couple HBX-1 bung extenders before I replace the bad WBO2, but was also hoping I could get some more experienced eyes on my Global File and a datalog. There are a few things that seem to stand out, and I was hoping for confirmation and any other comments:
  • AFR Right is way bad. You can see readings intermittently in the datalogs (I'm using left only for this tune).
  • AFR Left seems to be all over the place, is this normal? I'm not sure how much variation from target I should see, but it zig-zags pretty heavily. It looks like the EFI is having a difficult time regulating AFR.
  • I brought the timing down from the original template because 44° advance at 3K seemed high for a BB, but it seemed to run better up there.
    • I've double checked with a timing light and everything is accurate.
    • My only theory is that my cam & heads have a pretty inefficient burn and the high advance is appropriate - but 44 scares me.

  • I know my maps aren't super smooth yet, I'm still at an early stage and not very confident on what to pay attention to while I tweak.

If any experienced tuners have the interest to take a look, I'd me very appreciative of your feedback and comments. Kind Regards, Danny
Link to Global File, Datalogs & cam card: https://drive.google.com/open?id=1A_...NyqnbRmlcxFtVd
BB 521
Kaase P51 heads
Dominator EFI