Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Dominator not entering Closed Loop

  1. #11

  2. #12
    Join Date
    Nov 2014
    Location
    Ont. Canada
    Posts
    978

    Default

    I don't see anything in your tune that would stop it from going into Closed Loop. But I'm confused as to why you rewired the WBO2 into the J2 connector?

  3. #13

    Default

    My first WBO2 sensor got hit, ripped the white wire out of it, and started reading whatever my gauge was maxed out at. I sent the ECU to Holley in fear that I had fried it, and they said everything tested out fine. Get it back, install a new sensor in a different location, and the sensor wouldn't read anything other than 27.1. So I got ANOTHER sensor and wired it to the J2 plug and now my AFR reads correctly. However, since the AFR left says “unplugged”, I'm wondering if it won't enter CL because it senses that something is missing? I'm afraid to rewire the WBO2 in fear of burning another one up.

  4. #14
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    19,570

    Default

    Quote Originally Posted by Hoyt05 View Post
    In my Engine Parameters, I have "NTK", "2" & "Right Only" selected for respective values.
    Quote Originally Posted by Hoyt05 View Post
    However, since the AFR left says “unplugged”, I'm wondering if it won't enter CL because it senses that something is missing?
    I think this is your Closed Loop problem. I don't think you can select "2" WBO2 sensors with only one WBO2 sensor.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, FRPP 3.31 gears, Moser 31 spline axles, Cobra Trac-Lok differential, 4-disc brakes/Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  5. #15

    Default

    So how do I wire it up if my J1 port is messed up according to the Holley tech?

  6. #16
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    19,570

    Default

    Now I'm not sure about my post #14. Contact Holley Tech Service (LINK).
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, FRPP 3.31 gears, Moser 31 spline axles, Cobra Trac-Lok differential, 4-disc brakes/Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  7. #17

    Default

    Holley Tech Service agrees. So I will repin my J1 WBO2 with my old sensor and leave the parameters to Right Only and see if that helps. Thanks guys!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us