Results 1 to 6 of 6

Thread: Holley Terminator engine died suddenly, now no start.

  1. #1

    Default Holley Terminator engine died suddenly, now no start.

    I've had the Holley Terminator installed on my '85 K10 with a 350 SBC for about 8K miles with no problem until this evening. Started truck it fired up and ran normal, then without warning the engine just died. When I cycled the key to attempt to restart the fuel pump did not cycle on, the gauges read error and under the WBO2 value, it reads unplugged. TPS will not register, it stays at 0%. Battery volts read 20V and the number does not change even while cranking. I cleaned & checked the grounds, disconnected power for 5 minutes to try to reset the unit. Then called Holley, went over the truck with them for three hours, they say they've never seen this before. We tried updating the firmware to V5 with no change at all. Also will not do a TPS Autoset, it says there's no voltage change. I'm lost, the truck has ran perfectly up until this evening and it all went at once. Sorry for the long post, if someone has any advice I'd greatly appreciate it.

  2. #2

    Default

    Kudos to having a K10. Ks are so awesome. When you had tech on the phone, didn’t they offer to check your ECU for you if you’d send it to them? Three hours on the phone with one of those guys you to had to have checked both fuses and so on. From what I’ve learned, as long as your handheld don’t say searching for ECU, you're still in the game.

  3. #3

    Default

    Well we determined that the ECU is functioning properly as well as the handheld. They are communicating with each other as well. I believe this is what baffled them the most. Trying to avoid sending it to them if possible, due to this being my only vehicle and I'm not sure how I'm going to get to work. It may get a carb put back on if I can't sort it out by Monday.

  4. #4
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    23,073

    Default

    Quote Originally Posted by Kpoff View Post
    When I cycled the key to attempt to restart the fuel pump did not cycle on, the gauges read error and under the WBO2 value, it reads unplugged. TPS will not register, it stays at 0%. Battery volts read 20V and the number does not change even while cranking.
    It's acting like there isn't a valid Global File uploaded into the ECU. I'd try creating a fresh Global File from one of the base calibrations. (You can copy & paste the Base Fuel & Timing Tables.)
    http://forums.holley.com/showthread....2193#post72193 (EFI Software/ECU Firmware Problems)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  5. #5

    Default

    I'm gonna give that a shot first thing this morning. I'll let you know what happens. Thanks.

  6. #6
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    23,073

    Default

    Quote Originally Posted by Kpoff View Post
    I cleaned & checked the grounds, disconnected power for 5 minutes to try to reset the unit.
    I'd also try disconnecting the battery for 20 minutes, not just 5 minutes. Might as well, you have nothing to lose.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us