I spent last night trying to get DataLinkII V4.1.1 and Racepak Pro II to connect using serial port to enable Ana-B. This was the first time in 5 years we needed to use serial port.

At first I took my universal USB-Serial adapter (Prolific PL-2303 XA chip), but DataLinkII gives "ERROR: Receiver timeout on serial port COM14"
Next I let my Win 7 64 bit to upgrade the driver to latest version (Search automatically for updated driver software) and then after restart there was yellow rectangle in Device Manager next to port. I have used this adapter for years, but never tried to use it with Pro II serial port before. Now I'm stuck with this... uninstalling & removing the driver and installing the old driver back don't work either.

Since there was a dead end with adapter I took another PC with physical COM-port next to dragster and soldered together a straight DB9 DTE-DCE (male-female) cable where RX, TX and GND where connected, but no handshaking. At this time I got "ERROR: Protocol error". Then I run out of battery and did not have time to put breakout box between connectors and debug more.


We have never used the original serial cable which has been damaged at female end (at least it was our guess that it is original - or it is from MSD...). I tried to beep connectivity between pins to find out the handshaking thing before I soldered new cable, but it did not make any sense - so I binned it.

Should the cable be straight 2-2, 3-3, 5-5 cable?
What kind of handshaking is needed?
Pins 1 & 9 won't be connected I guess since those are used for charging the Pro II.

What are the following com port settings?
- Bits per second
- Data bits
- Parity
- Stop bits
- Flow control

Is there need to adjust FIFO buffer settings?

I hope to get the answers soon so we can continue our test session.