I am having no luck at all troubleshooting the issue with my new TCM. I have a 1994 AOD-E, freshly rebuilt, behind a 3.8 V6, in my 1988 Mercury Cougar.

To make a very long story short, I hooked up the TCM with the matching harness, tapped into my vehicle where need be for the functions (manual bump, TCC lock, sport mode, TPS), and ran the initial setup. Everything checked out okay. When I shift through all gears on the column, the handheld reads correctly. The handheld also reads my throttle input correctly, and seems to read my trans temp too, as well as changing from calibration A to B when I hit my 'sport mode' button.

Backing out of my driveway, reverse works, but when i put it into overdrive, the transmission goes to second gear, and stays there, even though the handheld SHOWS that it has given the commands to change to next gears. As I drive, I can watch on the screen as it changes all the way through 4th gear, but the transmission never actually shifts. Same thing happens if I put the car in second, or first, on the column.

Also, after calibrating the TPS in initial setup, the throttle input gauge on the handheld, as I said, works fine, but there is an error code 'H' in the diagnostics section. The manual says that means the system 'experienced an out of range condition'. I do not know if this is related to my issue, but I cannot make the code go away, no matter how many times I recalibrate.

So far, my troubleshooting has included:

-Replacing the torque converter
-Replacing the valve body
-Replacing the EPC solenoid
-Replacing the entire TCM module(it was suggested by a tech at MSD that it may be defective)
-Having my transmission builder take the entire trans apart a second time, and check for faults/damage
-Having ANOTHER transmission shop take the trans apart a THIRD time, and check for faults/damage
-Checking all my wiring for any shorts or improper connection

Its been over a year since I've done this transmission swap, and I cant find anyone with a solution, I just want to drive my car again. I purposely replaced everything possible related to the transmission with high end parts, right down to Stainless ARP bolts, and a Lokar shift linkage. Its quite inferiorating having pulled out all the stops on this build and, so far, it being a failure.

Please, any help or ideas would be greatly appreciated.




Tyler Colley