Results 1 to 10 of 10

Thread: Rev limiter won't work on Ready-To-Run.

  1. #1

    Default Rev limiter won't work on Ready-To-Run.

    Hi Folks. I've just installed my second #8529 Ready-To-Run Distributor in my Olds 442. I sent the first one back after it wouldn't give me a tach/rev-limiter signal, and now the replacement is the same problem. We rev up to 2700 so it'll limit at 5400 RPM. We ground the gray tach wire, but the tach doesn't drop to zero. We checked the wire that we are grounding, and it's good. I'm afraid that this unit has the same problem as the first one? Either the instructions are wrong (we watched the YouTube video and it looks like we're doing it all correctly? Thanks, Wayne

  2. #2
    msdtech1955 Guest


    Try just a "quick" tap to ground (just a fast tap).

  3. #3


    Hi, we tried a quick tap, 1-1/2 seconds, 3 seconds, the tach needle didn't flinch?

  4. #4

    Default Rev-Limiter won't work on MSD 8529 Plug & Play?

    Hi. I had it out for a burn with no Rev-Limiter. I can't keep doing this, it wants to go to 6500 just like that! Gotta be quick on the shifting!1st & 2nd is zero traction and she just starts to hook 1/2 way through 3rd? I NEED a solution here? Thanks, Wayne

  5. #5
    MSDTECH80 Guest


    Is the tach wired directly to the gray wire, or to negative side of the coil?

  6. #6


    We tried it both ways, it's like the wire isn't giving any signal out of the Distributor and the tach just works because it's hooked to negative on coil?

  7. #7
    MSDTECH80 Guest


    The tach output circuit on the distributor is bad. The module will need to be replaced.

  8. #8


    So I have to return this unit as well, that's 2 for 2. Because I'm running a Billet roller cam, I have to change the bronze distributor drive gear each time I change the distributor, these are around $80.00 a pop! I'll pull this unit and send it back to your people.

  9. #9


    Referring back to MSDTECH80's question. In order to see the Rev-Limiter Verification, the tach needs to be connected to the gray wire of the distributor. The tach will not respond to the setting of the rev-limiter if it's connected to the coil instead of the gray wire.
    The reason the tach should drop to zero during this process is because the signal is being grounded, then the tach should sweep up to the new rev-limit value after the gray wire is removed from ground.

    Referring back to msdtech1955's response. The window of time the gray wire needs to be grounded is tight. If the wire is held too long to ground, or not long enough, the setting will not take.
    As msdtech1955 was recommending, just try a short tap (don't count 1-Mississippi, etc.) and watch the tach response (while it's connected to the gray wire).

  10. #10


    Did this issue ever get resolved? I'm having the same problem and it's driving me nuts!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us