Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: NEED TUNING HELP, PLEASE

  1. #1

    Default NEED TUNING HELP, PLEASE

    I have been struggling for the past few weeks trying to get my engine to run properly. The major problem I am having is that when the engine is dropping RPM (i.e. coming to a stop and pushing in the clutch, or dropping from 2000+ rpm) it will not catch itself and idle, instead it struggles and dies.



    I have tried several combinations with the programming but still haven't found that sweet spot. I have listed my engine combination and current program setting below. Thank you to all in advance who put forth their suggestions. I am not a pro at this so I will take any advice I can on getting this car up and running properly.





    Engine
    Specs:


    LS2 block bored .030 (370 cid)

    Stock crank (3.622)

    Eagle Rods (6.125)

    JE Pistons

    Stock LS3 heads

    Comp Cams chromoly roller rockers
    (1.


    Lunati dual valve springs (.650)

    Lunati Voodoo cam (227 / 233 @
    .050, .584 / .584 Lift)


    FAST LSXr 102mm intake

    Nick Williams 102mm cable
    throttle body


    Stock LS3 Injectors (41 lb/hr) w/
    FAST injector spacers


    Stock LS3 Coils

    NGK iridium plugs (gap .040)

    Taylor Thunder Volt 8.5 plug
    wires


    Hedman Hustle headers (1 7/8”
    primaries, 3”collectors)


    LS3 2 bar MAP sensor

    LS1 style IAC

    LS1 style IAT sensor

    LS3 cam position sensor

    LS3 crank position sensor

    Aeromotive Stealth fuel pump

    Aeromotive fuel pressure
    regulator (set @ 60 psi)






    Current
    programming:


    Cam setting (MILD)

    Target RPM (1000)

    Throttle Blade @ Idle (3%)

    BARO @ 5280 elevation (24.4 “HG)

    MAP idle @ 5280 elevation (12.5
    “HG)


    Fuel Pressure (60psi)

    A/F Ratio

    Idle
    (14.4)


    Part
    Throttle (13.9)


    WOT
    (13.0)


    Injector Duty % @ idle (2%-3%)

    Ignition Timing

    Idle
    (22 degrees)


    Part
    Throttle (35 degrees)


    WOT
    (I haven’t got this far yet, still at default setting)


    Vacuum (12 inches)

    MAP sensor adjustment

    Linear
    @ 128.13


    Offset
    @ -0.31


    Enrichment
    @ 6%


    TPS sensor adjustment

    Enrichment
    @ 11%









  2. #2

    Default NEED TUNING HELP, PLEASE

    Have you checked the throttle position sensor wiring? It seems that a
    few of us have found the 0-5 volts and +12 volt wires were in the wrong
    locations on the harness to the TPS.



    http://www.atomicefi.com/forumLS.aspx?g=posts&t=17888



    Before
    I fixed mine, about half of the time the idle would surge a few hundred
    rpm and frequently it would want to stall when slowing down for a
    stop. Since I swapped the wires I have burnt about a tank of fuel, it
    stalled once but that I believe was my fault.

  3. #3

    Default NEED TUNING HELP, PLEASE

    I already checked it and it appears to be pinned correctly. I will however go and check it again, never hurts to double check wiring.

  4. #4

    Default NEED TUNING HELP, PLEASE

    I double checked the TPS, CAM, IAC, IAT and MAP sensor pin outs and everything looks correct.

  5. #5

    Default NEED TUNING HELP, PLEASE

    Hello, is anyone there??



    I am surprised that I have not heard from MSD with some ideas and suggestions to solve my problem, especially with all of the information I have provided.



    I really hope that after spending a great deal of money on this system I didn't make a mistake with going with the Atomic LS EFI instead of a traditional factory ECU and injection.

  6. #6

    Default NEED TUNING HELP, PLEASE

    Im having the same problem with my setup to I'm running a stock 5.3 with a th350 trans. Honestly I'm having serious regrets buying the msd system. My control module actually went bad after about a month of having it on. I no longer having any faith in the system because its so tempermatic it'll run great some days and others itll act up doing the same thing your describing

  7. #7

    Default NEED TUNING HELP, PLEASE

    72gmc wrote:
    Im having the same problem with my setup to I'm running a stock 5.3 with a th350 trans. Honestly I'm having serious regrets buying the msd system. My control module actually went bad after about a month of having it on. I no longer having any faith in the system because its so tempermatic it'll run great some days and others itll act up doing the same thing your describing

    Hey 72gmc, what are the specs of your engine and what are some things you have done to remedy it's issues?



    I can't believe another day has gone by and still no response from MSD.

  8. #8

    Default NEED TUNING HELP, PLEASE

    Im running an 03 5.3 100% stock. Its hooked to a th350 trans. I'm running a holley hp700 in line fuel pump with a holley fuel pressure regulator. I turned my tps enrichment down to 20? it makes the truck more drive able at least for now. It still acts up at random times. When coming to a stop the idle drops and if I get into it hard enough from a stop it'll die out. Sometimes the motor will start surging if im at a stop light. If i rev it up in park when the rpm comes down it drops down real low then levels out. I've checked my fuel pressure and its always within msds recommendations. I've heard of people having the tps wiring issues but mine appears to be wired correctly. I'm really running out of patience with the system and msd has been doing a whole lot of nothing to help me resolve any of my problems.

  9. #9

    Default NEED TUNING HELP, PLEASE

    IM_JONESY wrote:

    I have been struggling for the past few weeks trying to get my engine to run properly. The major problem I am having is that when the engine is dropping RPM (i.e. coming to a stop and pushing in the clutch, or dropping from 2000+ rpm) it will not catch itself and idle, instead it struggles and dies.



    I have tried several combinations with the programming but still haven't found that sweet spot. I have listed my engine combination and current program setting below. Thank you to all in advance who put forth their suggestions. I am not a pro at this so I will take any advice I can on getting this car up and running properly.





    Engine
    Specs:


    LS2 block bored .030 (370 cid)

    Stock crank (3.622)

    Eagle Rods (6.125)

    JE Pistons

    Stock LS3 heads

    Comp Cams chromoly roller rockers
    (1.


    Lunati dual valve springs (.650)

    Lunati Voodoo cam (227 / 233 @
    .050, .584 / .584 Lift)


    FAST LSXr 102mm intake

    Nick Williams 102mm cable
    throttle body


    Stock LS3 Injectors (41 lb/hr) w/
    FAST injector spacers


    Stock LS3 Coils

    NGK iridium plugs (gap .040)

    Taylor Thunder Volt 8.5 plug
    wires


    Hedman Hustle headers (1 7/8”
    primaries, 3”collectors)


    LS3 2 bar MAP sensor

    LS1 style IAC

    LS1 style IAT sensor

    LS3 cam position sensor

    LS3 crank position sensor

    Aeromotive Stealth fuel pump

    Aeromotive fuel pressure
    regulator (set @ 60 psi)






    Current
    programming:


    Cam setting (MILD)

    Target RPM (1000)

    Throttle Blade @ Idle (3%)

    BARO @ 5280 elevation (24.4 “HG)

    MAP idle @ 5280 elevation (12.5
    “HG)


    Fuel Pressure (60psi)

    A/F Ratio

    Idle
    (14.4)


    Part
    Throttle (13.9)


    WOT
    (13.0)


    Injector Duty % @ idle (2%-3%)

    Ignition Timing

    Idle
    (22 degrees)


    Part
    Throttle (35 degrees)


    WOT
    (I haven’t got this far yet, still at default setting)


    Vacuum (12 inches)

    MAP sensor adjustment

    Linear
    @ 128.13


    Offset
    @ -0.31


    Enrichment
    @ 6%


    TPS sensor adjustment

    Enrichment
    @ 11%






    Just curious on the setting you posted regarding the (Throttle blade @ Idle 3%)

    How are you able to know if your blade is opened @ 3%?

    If your talking about the TPS reading 3% from the handheld at Idle then thats your problem! If your talking about the actual throttle body blade being adjusted manually to exactly 3% i'm curious to how you did that? Whats your IAC counts when idling and at operation temp? Either way bro, Im here to help and have spent hours on the dyno tuning and troubleshooting this EFI system so ill try my best to help you since MSD hasnt yet!

    Also..... your A/F settings seem way to rich for this type of EFI. try setting your idle @ 14.8

    Part @ 14.6

    WOT @ 12.8

    It must smell super rich at idle right?

    And why are you running a 2 Bar MAP sensor on a non Boosted engine?


  10. #10

    Default NEED TUNING HELP, PLEASE

    Hey Lenny,



    I have been messing with the IAC count for about a week now and I have been have some good luck. What MSD fails to mention is that the IAC CNT is more important than the "none running" throttle blade percentage. Opening the blade lowers the CNT and closing the blade raises the CNT.



    As I was digging through the World Wide Web I came across a posting that suggested the IAC CNT be between 10-20, ignore the % its meaningless. Don't try and do this at once, adjust it until it struggles at idle and don't make any adjustments until the PCM goes into a LEARNING ON state. Drive it, shut it down and repeat the process until your CNT is low enough to allow the engine to be happy.



    I just did another adjustment this evening and my CNT at operating temp and LEARNING ON was ZERO (0) and my cam setting set to performance, the mild setting wasn't dumping enough fuel. I still have more adjustments to make to get it fine tuned but at least for now its becoming less of a burden to drive.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us