Results 1 to 9 of 9

Thread: TPS incorrect reading/wiring?

  1. #1

    Default TPS incorrect reading/wiring?

    Ok I have just noticed my TPS is only reading 0-87% I thought it was the carpet in the way but it wasn't. Same reading even with the cable removed? So the atomic is never reading WOT.



    Can you please attach the correct pin out diagram for the tps sensor. Would be good to double check the wiring.



    I just checked between;

    black & blue wire, got 5.0v @ 0 & 87% throttle

    Black & red wire, got 2.0v @ 0% & 4.1v @ 87% throttle



    Does my tps pinout need changing, would this be why I'm not reading past 87%?

  2. #2

    Default TPS incorrect reading/wiring?

    The wire colors on the short extension should match up with the colors on the 8-pin going in to it. You should read 5V if you measure across the orange and black wires. If you read across the black and blue wires, your voltage should read very close to 1V at closed throttle and 4-4.5V at 100% throttle. Your range is way too short right now, so it cannot reach 100%. It needs to span from at least 3.3V to go from 0-100% (it will auto calculate the 100% point if the span is larger than this). The pinout going into the TPS itself should be:

    A (1) orange -- 5V

    B (2)=black -- signal ground

    C (3)=blue -- signal



    I believe on our connector, it has a small 1,2,3 on the back of it, which correspond to A,B,C. If those are correct, look at the 8-pin end and make sure the corresponding pairs match up. They should be:

    A=Brown - future use

    B=Pink - future use

    C=Brn/White - ground, matches up with black on short pigtail

    D=not used

    E=Green - TPS1, matches up with blue on short pigtail

    F orange - 5V, matches up with orange on short pigtail

    G=Violet - TPS2, future use

    H=not used


  3. #3

    Default TPS incorrect reading/wiring?

    Ok, I have no idea why those emoticons showed up in there, they are not supposed to be there.

  4. #4

    Default TPS incorrect reading/wiring?

    Thanks for the reply Mike, I checked the pin out and the orange and blue wires were the wrong way round! TPS now read 0-100%, WOT is now seen on the display. Voltage showed 0.7-4.5v

    So looks like that problem is solved. I am hoping this gets rid of the hunting idle that so many of us seem to be experiencing. Someone has mentioned on here that the incorrect TPS wiring was causing incorrect IAC control with the engine running, I will see how it behaves when I run it again and report back

    Cheers,

    Jonny

  5. #5

    Default TPS incorrect reading/wiring?

    Jonny,



    Any updates? I'm having TPS issues as well.

  6. #6

    Default TPS incorrect reading/wiring?

    I changed the wiring to how it should be (in above post) it now reads 0-100% hunting/stalling at idle has gone. Will go from WOT to idle now with no problems. Have not driven it under load yet tho. Def check your wiring, seems like there are quite a few kits out there wired wrong!!

  7. #7

    Default TPS incorrect reading/wiring?

    That would have been me who in detail described and identified the TPS/idling problem many of you have posted about. I have replied to many posts with the solution being incorrect wire locations on the tps plug but it seams like no one wanted to listen. Anyways, Im glad you figured out the problem. I resolved this issue almost 2 years ago and I notified MSD of the improper wiring of the tps connector, I dont understand why they dont just post a bulletin in the forum advising everyone with tps voltage and percentage issues to check if the wires are in there correct pin location before they start pulling out volt meters and making people think they have a worn out or cheap throttle body when that isnt the issue.


  8. #8

    Default TPS incorrect reading/wiring?

    Yeh as soon as I read your post I checked it out, so thanks for that. I still havnt driven it yet since I sorted out the idle (hopefully dosnt stall everytime I come to a stop anymore)

    MSD seemed to hide the fact that they had the wiring wrong in their responses, I think they should inform everyone to at least check this via a new thread on here.....

    Feel real sorry for the poor guy who has spent thousands on new MSD coils/Tb's/fuel system to try and fix his hunting/stall at idle

    Hopefully nothing else has been pinned out wrong in the harness, they must have some top notch people in the Qc dept!

  9. #9

    Default TPS incorrect reading/wiring?

    My two pins were incorrect, swapped them around this morning and it runs way better. Thanks for the info on the pin-outs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us