Results 1 to 2 of 2

Thread: Troubleshooting Checklist - Holley EFI

  1. #1
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    19,262

    Default Troubleshooting Checklist - Holley EFI

    • Check fuses (& correct amperage fuses), relays and their sockets. Fuel pump wiring too.
    • Is the ECU main power & ground wired directly to the battery? Battery acts as a great capacitor/filter. (LINK & LINK)
    • Cable from negative battery post to engine block, engine block to frame and #8 AWG wire from body to battery? (LINK)
    • Check the switched (keyed) 12 volt red/white wire connection. 12 volt ignition power too. Very important!
    • Is the System Relay sending 12 volts to the (red) fuel injector wire and to the (green) fuel pump trigger wire? (LINK)
    • Inspect the entire wire harness for chafing against metal. Check ignition switch too. Custom I/O wired correctly?
    • Perform a "wiggle test" on the entire wire harness/connectors from ECU to engine and Ohms continuity tests.
    • Is a shielded wiring harness used with the crank and/or cam sensors? Magnetic sensors at least need twisted wires.
    • Try completely disconnecting the battery for 20 minutes. This "resets" some unusual ECU issues.
    • Reflash ECU firmware to erase large capacity of internal datalogs that won't Delete. "Delete All" reformats the memory.
    • Completely remove corrupted EFI software from "Control Panel", "Documents", "C:Drive", and install a fresh download.
    • Does the laptop have the latest software & USB drivers? (https://www.holley.com/support/resou...Fuel_Injection)
    • Does the ECU have the latest firmware? (https://www.holley.com/support/resou...Fuel_Injection)
    • Are there any high voltage/noisy electrical components near the EFI wire harness or sensitive actuators/sensors?
    Resistor type spark plugs & good wires should be used with an EFI system, to suppress electrical noise/interference.
    • Did the routing of the spark plug wires change at all? Are plug wires in good condition? Check rotor phasing too.
    • Is there something (accessory/component) that turns on or off, when the EFI malfunctions?
    • Don't tune on the hand-held/TSLCD and a laptop. Both can be connected but use one or the other to edit/tune with.
    • Ensure the ignition timing is synchronized. Review datalog for RPM Errors. Record a System Log if necessary.
    • Erroneously set "Warning Enabled Timing Offset" parameters in the "Sensor Scaling/Warnings" (System ICF, I/O ICF)?
    • Ensure the Inductive Delay is also accurately adjusted. If it's way off, driveability, power & misfires can result (LINK).
    • Does the Data Monitor display a legitimate RPM reading while cranking? If not, there's no RPM signal.
    • What does the ignition system consist of? Are the Ignition Parameters configured correctly?
    • Are the crank & cam sync sensor signals setup/timed correctly (triggering)? Output Setup Type & Dwell Time?
    • Ensure a Hall-Effect sensor is entered as "Digital Falling" or "Digital Rising", and a magnetic VR sensor as "Magnetic".
    • Ensure a 5 volt crank or cam sensor isn't wired to a 12 volt reference source, and vice versa.
    • Is the crank sensor air gap set within specification and is the wiring +/- polarity (VR magnetic) correct?
    • Is the crank trigger's sensor air gap changing under high load (crankshaft flexing/endplay)?
    • Inspect the ignition system wear items (spark plugs, wires, cap, rotor, coils, pickup modules, etc.).
    • Ensure each cylinder is consistently firing using infrared temp gun, timing light and/or injector noid light.
    • Fully charge the battery! Ensure the alternator is properly charging the electrical system. Check battery & cables too.
    • Learn Table & injector Duty Cycle % are good troubleshooting tools. Significant new changes means something is wrong.
    • Check the fuel pressure and fuel system components for leaks and restrictions (wiring, plumbing & venting).
    • Use the appropriate amount of timing advance at idle. Stock cam - 20°, performance cam - 25°, radical cam - 30°.
    • Are throttle blades adjusted to achieve an IAC Position of 5% at hot idle? TPS Autoset performed?
    • Ensure the proper type of Advanced Idle Control is selected in Idle Settings. "Slow" may provide the best idle quality.
    • If exhaust condensation is thermally shocking the WBO2 sensor, move sensor probe out of direct exhaust stream (LINK).
    • Ensure there are no exhaust leaks upstream of the wideband O2 sensor(s) to prevent a false lean condition.
    • Ensure sufficient length of exhaust piping beyond WBO2 sensor(s) to prevent a false lean condition at idle & low RPM.
    • Any problem that prevents combustion, causes a false lean condition (misfiring, spark blowout, etc.).
    • Leaded racing fuel will greatly decrease a wideband O2 sensor's longevity to within 50 hours. (Normally 500 hours.)
    • Is the Bosch wideband O2 sensor malfunctioning only under boost? NTK WBO2 sensor is better for boost.
    • Ensure you're using the latest EFI software & ECU firmware (LINK); it has "Oxygen Sensor Control Updates" (LINK).
    • Low battery voltage will cause the wideband O2 sensor's initial heating cycle to malfunction (LINK).
    • Ensure there are no vacuum leaks at throttle body and intake manifold. Some use a steel plate with two gaskets.
    • If not using an electronic Transmission or Drive-By-Wire, those ICFs must be removed from the Global File Toolbar.
    • Don't change naturally aspirated base calibrations to forced induction MAP sensor; Fuel Table (lb/hr) will be dead lean.
    • Test the MAP sensor and its vacuum/boost hose for leaks, with a Mityvac vacuum/pressure pump.
    • Upgrading to V2 software requires immediate attention: Fuel Prime %, Inductive Delay & AE vs TPS/MAP RoC Blanking.
    • Diagnose all sensor values on Data Monitor for legitimacy, and retrieve any sensor codes if applicable.
    • Review datalog of driveability incident. Scrutinize air/fuel ratio and timing advance. (LINK, pages 4-10)
    • General engine maintenance (air & fuel filters, plug gaps, valvetrain integrity/adjustment, exhaust smoking, etc.).
    May God's grace bless you in the Lord Jesus Christ.

    '78 BRONCO: 508" stroker, TFS heads, 11:1 comp ratio, Dominator MPFI & DIS, cold air induction, Spal dual 12" fans/aluminum radiator, dual 3" exhaust/Magnaflow mufflers, Moroso vacuum pump, Accusump, engine oil & trans fluid coolers, 100HP progressive dry direct-port NOS, A/C, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, traction bars, 4" Skyjacker lift, 35" mud tires

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    19,262

    Default General Information & Tuning Help

    Quote Originally Posted by Danny Cabral
    EFI Software & ECU Firmware Versions:
    EFI SOFTWARE: click "Help" tab (top toolbar) & "About Holley EFI".
    ECU FIRMWARE: click "Sync With ECU" & "Get ECU Info" (Key-on/USB connected).
    The latest EFI software & ECU firmware can be downloaded here:
    https://www.holley.com/support/resou...Fuel_Injection (Holley EFI Technical Library)
    http://documents.holley.com/techlibr...r10546rev1.pdf (HP & Dominator Quick Start Guide)
    http://documents.holley.com/techlibr...rmwarerev1.pdf (How To Update ECU Firmware)
    Before updating firmware, ensure the current Global File is saved somewhere, since it will be erased from the ECU.

    Latest V4 EFI Software & ECU Firmware:
    The latest Holley EFI V4 software & firmware can be downloaded HERE.
    Read the V4 Software Overview document HERE, or in the EFI software "Help" Contents.
    Successfully install the new V4 EFI software (laptop), before installing the V4 ECU firmware.
    Ensure the Holley EFI software is not open and the ECU is not powered on/connected when installing the new software.

    EFI Software Help Information/Instructions:
    ‒ On the top Toolbar, click "Help" & "Contents". This opens all Help topics.
    ‒ When navigating the software, click "Help ?", drag it to any parameter and click again.
    ..This automatically opens the definitions for that specific parameter.
    ‒ Tuning information can be read by clicking the F1 key, when you're viewing any screen.
    http://documents.holley.com/techlibr...10555rev17.pdf (Holley EFI Wiring Manual)
    Quote Originally Posted by Danny Cabral
    Corrective Action For Failed Wideband O2 Sensor:
    If you suspect a failed WBO2 sensor, and your Fuel Table is well tuned, you can disable Closed Loop (in System Parameters),
    and the engine should run fine until a replacement WBO2 sensor arrives. You can do this to determine if the WBO2 sensor is at
    fault (at least at idle), because in Open Loop mode, the ECU ignores the WBO2 sensor. So if the engine starts running good in
    Open Loop mode, you've found the problem. Just ensure that you don't disable Closed Loop mode while the Learn Table is
    corrupted from a failed WBO2 sensor. Clear the Learn Table (if the percentages are erroneous from their nominal values), or
    load the last "known to be good" Global File. Also, if the ECU detects a WBO2 failure, it will go into Open Loop mode.

    • Diagnose the following:
    All sensor values correct on Data Monitor?
    Failed WBO2 sensor corrupted Learn Table (unusual %)?
    Exhaust leaks upstream of the WBO2 sensor?
    Ignition misfire? (WBO2 sensor will read lean.)
    Battery/charging system functioning properly?
    Consistent fuel pressure? (Disconnect vacuum hose to measure static psi.)
    Inspect wire harness/connectors for damage and ensure it's not near any high voltage components.
    http://www.youtube.com/watch?v=s3R8whD3ZWg
    (Interesting WBO2 sensor diagnosis - it works!)

    • Ensure you're using the latest EFI software & ECU firmware (LINK); it has "Oxygen Sensor Control Updates" (LINK).
    FYI: Low battery voltage will cause the WBO2 sensor's initial heating cycle to malfunction (LINK).
    Quote Originally Posted by Danny Cabral
    Learn Issues (Self-Tuning):
    Check the Closed Loop & Learn settings in System ICF.
    Ensure both are Enabled, and "Learn Gain" is 100%.
    Learning won't happen if the idle RPM, MAP or TPS is unstable/invalid (NOTE).
    Try blocking off the IAC passage to see if it stabilizes the idle. If so, it may be IAC related.
    Ensure the Closed Loop & Learned Compensation Limits haven't reached their percentage limits.
    Initially, if the Closed Loop Advanced Control (1-5) is set too high, it can intermittently inhibit Learning.
    Also, ensure Learning isn't working because of repeated "RPM Errors", causing repeated ECU "syncing".

    • Closed Loop & Learning happens at all RPM, provided the Closed Loop/Learn Parameters are programmed as such.
    The Coolant Temperature Enrichment % & A/F Ratio Offset tables must be at 100% & zero to enter Learn mode.
    You'll need to reconfigure these tables if you're running the engine colder than what the base calibration specifies.

    • Closed Loop & Learning isn't active during periods of acceleration enrichment or deceleration (zero TPS, 400 RPM above target idle).
    The engine needs to be at "steady-state" RPM for the Learning to function, at lower RPM.
    The Closed Loop Status has many momentary periods when it's inactive (Open Loop mode).
    This is normal due to the TPS & MAP based acceleration enrichment (transient fueling).
    Also, any "noise" on the TPS or MAP signal wire (false Rate of Change) will deactivate Closed Loop.
    http://documents.holley.com/techlibr...__statuses.pdf (Sensor Diagnostics & Statuses)
    Quote Originally Posted by Danny Cabral
    Typical No-Start Checks (Some of these don't pertain to Sniper EFI):
    Is the battery fully charged?
    Have you performed a TPS Autoset?
    Is the engine cranking fast enough (100+ RPM)?
    Does the Data Monitor display legitimate cranking RPM?
    Does the Data Monitor display legitimate sensor values?
    Does a Datalog indicate any RPM Errors?
    Is the throttle blade(s) open far enough to start?
    Are the crank & cam sensor/reluctor air gaps set correctly?
    Do the crank & cam sensors have power & ground?
    Keyed +12V red/white wire powered when cranking?
    Fuel pressure set to proper psi (Actual System Pressure)?
    Are the fuel injectors spraying fuel?
    Does the fuel pump prime for 5 seconds at key-on?
    Is the ECU controlling timing?
    Does a timing light indicate there's spark/ignition?
    What does your ignition system consist of?
    Correct Ignition Type entered in Ignition Parameters?
    Are the spark plugs fuel fouled/wet?
    Is the ignition timing synchronized with the ECU?
    Are you running in sequential mode? If so, check the cam sync sensor.
    Air or Coolant Temp Enrichment Modifiers erroneously set to 0% or 70%?
    The engine won't start if the throttle is opened beyond the "Clear Flood TPS" setting.
    Is it correctly wired as shown in the wiring manual? (Holley EFI Wiring Manual - LINK)
    Disconnect the ECU Main Power Harness for 20 minutes. This "resets" some unusual ECU issues.
    http://www.yellowbullet.com/forum/sh...0#post26386690 (Incorrect Digital Falling Signals - 4x Crank & 1x Cam)

    • If Data Monitor doesn't display consistent RPM, start troubleshooting the crank sensor.
    If all EFI wiring is correct, I'd record a Datalog and if necessary, a System Log also:
    http://forums.holley.com/showthread....p-SL-Data-Logs (Sensor Diagnostics & Datalogs)
    http://forums.holley.com/showthread....ents-Read-This! (Initial Checks & Adjustments - Read Steps #1-#6!)
    Quote Originally Posted by Danny Cabral
    Starting Issues - initially starts, but stalls immediately after:
    When it stalls, how does it die?
    Quick & clean (quick stall) = too lean*
    Spit & sputter (slow stall) = too rich
    Tune the After Start Enrichment accordingly.
    If engine stalls several seconds after starting, tune the Coolant Temperature Enrichment Table or After Start Decay Rate.
    May also be caused by using the wrong base calibration for the MAP sensor in use (Base Fuel Table excessively lean or rich).
    * If the tune is excessively rich, it can stall immediately after startup, due to flooding (extinguishing) the spark.

    Notes - starts & runs, but potentially could be better:
    If it starts worse, with the throttle cracked open, it's too lean.
    If it starts better, with the throttle cracked open, it's too rich (or throttle blades were closed too far.)
    The Cranking Fuel & IAC Parked Position are the "cranking air/fuel ratio". Tune these parameters.
    Adjust the idle speed screw on throttle body, to achieve an IAC Position of about 2% at hot idle.
    Some engines start better with more timing while cranking (Cranking Timing in Ignition Parameters).
    Ensure the ignition timing is synchronized: http://forums.holley.com/showthread....ing-Holley-EFI
    Sequentially injected engines will always crank slightly longer for the ECU to receive the cam sync signal.
    The new Quick Start "Fuel Prime" feature works very well, but be careful. Too much % will start fine cold, but not hot.

    • You can only tune the Startup Enrichment parameters after the Learning has self-tuned the Base Fuel Table and if the
    Coolant Temperature Enrichment & A/F Ratio Offset tables are acceptable. This is because the aforementioned parameters
    & tables are modifiers of the Base Fuel Table. Exception: Cranking Fuel lb/hr, Cranking Timing & IAC Parked Position %,
    because they function independently under 400 RPM (or whatever your "Crank To Run RPM" is).
    http://forums.holley.com/showthread....6254#post36254 (Good Starting Advice Thread - Especially posts #2, #4 & #6.)
    Quote Originally Posted by Danny Cabral
    Typical Idle/Running Issues:
    Has Learning finished self-tuning the idle area?
    Are you using the latest EFI software & firmware versions?
    Is the main power harness connected directly to the battery terminals?
    Is the Base Timing Table advance flat (same) in the idle area?
    Is Idle Spark control enabled and the Target Idle Speed (RPM) set?
    Is the Idle speed screw adjusted to achieve an IAC Position of about 5% at hot idle?
    Perform another TPS Autoset, whenever you adjust the idle speed screw on the throttle body.
    Is the proper "Advanced Idle Control" & "IAC Type" selected in the Idle ICF? "Slow" may be best.
    Try blocking off the IAC passage to see if it stabilizes the idle. If so, it may be IAC related.
    Are "Enable Closed Loop" and "Base Fuel Learn Enabled" the only parameters check marked?
    What's your Ignition Type and how are your Ignition Parameters configured?
    Is it possible that the ignition timing isn't synchronized with the ECU? (LINK)
    Using a timing light for misfire detection works well (watch for consistent flashing).
    Is the fuel pump running on a consistent +12V? Is the alternator/charging system working?
    Is the fuel pressure regulator adjusted to proper psi? Is the fuel pressure consistent?
    Is this a naturally aspirated engine and are you using a naturally aspirated base calibration?
    Ensure the Learning isn't working because of repeated "RPM Errors", causing repeated ECU "syncing".
    If you don't have an electronic transmission, remove the Transmission ICF from the top Toolbar.
    Are there any exhaust leaks upstream of the WBO2 sensor? Is the WBO2 sensor near the end of the pipe?
    Large duration (race) camshafts will exhibit a fluctuating AFR/false lean condition at idle & low RPM.
    Have you tried manually tuning the idle in Open Loop? (Disable Closed Loop in System Parameters.)
    If it runs right in Open Loop, you could have a defective WBO2 sensor or a wrong setting in Closed Loop/Learn Parameters.
    http://forums.holley.com/showthread....e-Tuning-Notes (EFI Idle Tuning Notes)
    Quote Originally Posted by Danny Cabral
    EFI AE In Carburetion Terms:
    "AE vs TPS Rate of Change" = carburetor accelerator pump
    "AE Correction vs TPS" = carburetor accelerator pump cam (shape)
    "AE vs MAP Rate of Change" = carburetor power valve function
    "MAP AE Time vs Coolant" (Decay) = carburetor shooter size
    "AE TPS vs Coolant Temp" = carburetor choke effect (in terms of AE)
    "MAP AE vs Coolant Temp" = carburetor choke effect (in terms of AE)
    "AE vs TPS RoC Blanking" = carburetor accelerator pump lever adjustment (feeler gauge)
    "AE vs MAP RoC Blanking" = carburetor idle transfer slot/circuit exposure (idle & off idle)
    "Coolant Temperature Enrichment %" & "A/F Ratio Offset" = primary carburetor choke functions
    "Target Idle Speed" & "IAC Parked Position" = carburetor choke fast idle cam & idle kickdown functions

    Additional Notes:
    You may also be interested in the injection strategy information found in this thread:
    http://forums.holley.com/showthread....amp-Paired-EFI (EFI Injection Strategies)
    • The "AE Correction vs TPS" changes the "AE vs TPS Rate of Change" based on throttle position.
    The "AE vs TPS Rate of Change" parameter functions on how slow or fast the throttle is opened.
    The "AE Correction vs TPS" parameter functions on throttle position at any particular moment.
    So it's possible that two similar data logs or incidents can have very different AE transient fueling.
    • The AE vs TPS Rate of Change is the easiest to tune:
    You can plot an Acceleration Enrichment lb/hr curve by watching the "live cursor" and air/fuel ratio at each TPS/MAP "Rate of Change" cell.
    This requires varying the amount of throttle to reach each consecutive cell for tuning. Increase the lb/hr value at each throttle point if it's too lean,
    and decrease the lb/hr value if it's too rich. Tune the "AE vs TPS Rate of Change" in neutral and tune the "AE vs MAP Rate of Change" in gear.
    Remember, the TPS RoC & MAP RoC (as seen on the Data Monitor & Data Logger) is the activity happening after the RoC Blanking value is applied.
    • For very slow TPS/MAP off-idle movement, the new "AE vs TPS RoC Blanking" & "AE vs MAP RoC Blanking" parameters need to be adjusted
    (in Fuel Modifiers/Fuel Control/Accel Enrichment). This is because the first cell value in the AE vs TPS/MAP Rate of Change tables
    are now always set to zero. These first zero cells are the new "AE vs TPS RoC Blanking" & "AE vs MAP RoC Blanking" parameters.
    • Also, ensure the 2nd cell value on your AE vs TPS Rate of Change scale isn't set too low (interpolation).
    You might be in between a 2nd cell value that's too lean, and a proper AE vs TPS RoC Blanking value.
    If AE tuning isn't taking effect, the Fuel Table may be too lean. AE can't be tuned until Learning finishes self-tuning the Fuel Table.
    Quote Originally Posted by Danny Cabral
    Defective ignition modules - common problem with MSD 8366 distributors.
    Replace the ignition module with a genuine GM ignition module.
    (This same rationale applies to Ford TFI distributors too.)
    ‒ Ignition module for MSD 8366 Pro-Billet Distributors:
    GM 19179578
    ACDelco D1943A
    http://www.rockauto.com/dbphp/x,cata...CO_D1943A.html
    http://www.msextra.com/doc/ms1extra/...EI_modules.jpg
    ‒ I'd also verify the GM HEI module polarity is wired correctly:
    https://forums.msdperformance.com/sh...0681#post10681
    http://www.megamanual.com/ms2/GM_7pinHEI.htm
    ‒ Apply heat sink (thermal conductive) paste on the bottom of the module before installing it.
    Often times, dielectric grease is wrongly used and will lead to an overheated (failed) module.
    Quote Originally Posted by Danny Cabral
    Dry Fire Testing a Nitrous Oxide Kit:
    If you'd like to "dry fire" test an N2O system, you must also set the Clear Flood TPS parameter above
    the N2O TPS Trigger (and don't move beyond it). An N2O stage can be "dry fire" tested with the:
    Key-On/Engine-Off
    N2O system armed (enabled)
    TPS Trigger set to 1%
    AFR Lean/Rich Cutoffs disabled
    Minimum RPM (RPM Trigger) set to zero

    Ensure the N2O bottle valve is closed during this procedure. The engine doesn't have to be cranking,
    "bumped" or running. The throttle position is the tricky part. You must be above the N2O TPS Trigger
    setting, but below the Clear Flood TPS setting. The "Pause Enabled" feature even works during testing.
    Quote Originally Posted by Holley EFI Help Definitions
    Laptop "Online" Communication With ECU:
    Next to the “Toolbox” button, is a button to indicate the following status of ECU/laptop communications.
    Offline: Is shown when the ECU is not powered or the USB cable is not connected.
    USB Link: Is shown when the ECU is powered and USB connectivity is established.
    However, the user has not chosen to select the “Online” mode,
    and the Laptop & ECU are not communicating with each other.
    Changes made at this time on the laptop, are not being updated in the ECU.
    Online: Is shown when the Laptop and ECU are communicating.
    At this point, changes made with the laptop are real-time updated in the ECU.

    "Get From ECU" & "Send To ECU" - ECU Sync window:
    When you connect a laptop and go "Online" with the ECU, you first want to click "Get From ECU". This updates your laptop with the latest
    ECU "state of tune". If you click "Send To ECU", you overwrite all the Learning the ECU has performed since the last time that laptop was
    connected (because you're not sending the latest, up to date values to the ECU). The only time you should click "Send To ECU", is if
    you're just sending a Global File change to the ECU and you haven't driven the vehicle since the last time the laptop was connected.

    Creating, Naming & Saving a Global File (Global Config Directory):
    You should name your Global File and save it in the EFI software. See below:
    Open the "Help" Contents ("Help" drop down menu), and read "Step-By-Step Beginner's Tuning".
    Or, at least read the "Quick Start Guide": http://documents.holley.com/techlibr...r10546rev1.pdf
    IF creating a new Global File Name (as opposed to just saving a change in an existing GF), it's much easier to click "File",
    "Save Global File As...", delete the Global File Name shown and just type in the new name you want without any backslash.

    Emailing Global Folders/Global Files (V4) & Datalogs:
    Your Global Folder and/or Datalogs can be emailed to yourself or other forum members. Click on their username, "View Profile", "About Me"
    & "Download vCard" for their email address. When emailing a Global Folder/File or Datalog, use your email's 'attachment utility' function and
    Browse through your computer's "Documents", "Holley", "HEFI" & "Global Folders"/"Global Files" (V4) or "Datalogs". V3 & earlier: Then right
    click on your Global Folder and Send To "Compressed (Zipped) Folder". Then select the zipped folder and attach it to the email. V4 Global
    Files & Datalogs (all versions) aren't required to be "zipped"; simply select & attach it to the email. The recipient now has your entire GF
    or Datalog in one easy step. If it's zipped from email, so download it to your Desktop (or wherever your PC saves it to), and unzip it.
    Then "Cut & Paste" the GF into "Holley" "HEFI" "Global Folders/Files" directory (located in Documents).

    ECU Date & Time:
    When you go "Online" with the ECU, the option to "Sync ECU Time" (ECU RTC) is at the top of the ECU Sync window. Then cycle the ignition key off/on.
    Quote Originally Posted by Holley EFI Help Definitions
    Revision "J" Level (or higher) ECUs:
    http://documents.holley.com/techlibr..._log_rev_2.pdf (Read "Version HEFI_0587.eep - Software V2 & up.)
    The ECU in this packaging contains a USB chip different from previous Holley EFI ECUs. This USB chip uses an "HID" driver. Drivers for this are already present on PCs and laptop computers. Due to this, there is no USB driver that is required to be installed to communicate with this ECU, via the Holley EFI software installation disk. When the ECU is plugged into the computer, it should automatically install the USB HID driver. Note that these ECUs can be identified on the sticker (on the back) as having a revision level of "J" or higher alphabetically (older ECUs had no revision level). Note that when installing the software, it WILL show the installation of a Silicon Labs USB driver. This is needed for older ECUs using this software version (LINK). The Revision Level "J" (or higher) ECUs also have Magnetic Crank/Cam Input Filtering capability, but that's another matter (LINK).

    New Magnetic Crank & Cam Sensor Parameters:
    There are new crank & cam sensor parameters for Magnetic type pickups in software version 2.2.0.3 & later. These only have an effect on ECUs marked with "Rev J" on the back. These only have an effect on ECU’s that with an ID# above 6000 on the label on the back. These parameters have no effect on older ECUs, which can be identified by not having a Revision level on their labels. If you have an older ECU, enter a value other than 0.00 volts, so the warning message stops appearing.

    The new variables are found in the System Parameters ICF: "Ignition Parameters", "Ignition Type", "Custom", "Configure".
    If the Crank Sensor - "Sensor Type" = Magnetic, or the Cam Sensor - "Sensor Type" = Magnetic, the following new variables appear for either:

    "Minimum Signal Voltage" - This parameter defines what the signal strength must be for the ECU to recognize it as valid for the crank, cam & IPU speed inputs. Anything below this threshold is considered background noise. This value can be set between 0 & 5V and the higher the setting, the more noise is rejected and the stronger the signal has to be before the ECU considers it valid. Practically speaking, the sensor's signal at the lowest speed (during cranking for instance) defines how high you can set this. Obviously, if you only have voltage level of 0.5V during cranking, you do not want to set it to 1V because the actual signal will be ignored. It is advised to start with a value of .35 Volts. If there is a problem picking up a signal during cranking, lower this value .05 Volts at a time until you get reliable triggering during cranking (valid engine speed), then multiply this value by 0.75. If there is a problem with noise causing false pulses, you can try increasing this value. This parameter can also be found in the "Input/Output ICF" as well, when the Input Type is set to "IPU Speed".

    "Filtering" - This is a variable that controls the new hardware based filtering used to help throw out short duration noise on the crank & cam inputs. A value of 1 represents the minimum filtering and 16 is the maximum filtering. Practically speaking, the sensors maximum frequency in combination with its strength determines how high you can set this. A 60-2 or 36-1 pattern generates a high frequency signal and you would almost never need anything greater than 8, and anything over 4 should be used with caution. For single pulse per fire crank signals & cam signals, the frequency is lower and you an get away with more filtering. If you use a filtering value that is too high, valid pulses can be filtered out at high engine speeds causing sync errors. You do not have to be under load to test for this. You might notice as you increase the crank filtering levels, you will have to increase the Inductive Delay values to keep timing from retarding at high speeds, since by its nature the filtering introduces a slight delay (LINK - page 2).
    Quote Originally Posted by Holley EFI Warning Notice
    Important Battery Charger Usage!
    Most battery chargers do not provide "clean" power to the vehicle and can cause voltage spikes that damage the ECU.
    This is especially true of most 16V battery chargers. Adhere to the following guidelines!
    ‒ Never use the "cranking" setting on a charger to start the engine.
    Do not set a charger to a charge current over 10 amps.
    Charge the battery sufficiently, before trying to start the engine.
    ‒ If using a 16V battery charger, do not turn on the ECU switched power, nor start the engine with the charger on.
    Make sure the charger is not charging over 18.5 volts.
    ‒ If the battery has sat for a long time, or is known to be discharged, it's best to charge the battery with everything
    DISCONNECTED from the battery, while the battery is being charged.

    ECU Main Power & Ground Cable Installation:
    The ECU main power cable MUST be connected directly to the battery posts/terminals. Do not connect the power to the starter or some other point other than the battery. The ground also needs to connect directly to the battery post/terminal. Distribution blocks or remote mounted posts are NOT acceptable. Make sure your vehicle has good/clean grounds from the battery to the engine block/cylinder heads (1 gauge minimum), and also from the engine block to the frame & body (4 gauge minimum). Do NOT use engine mounts, etc. for grounds. Proper grounding is imperative for proper EFI operation and to avoid damage to the ECU & other components. (LINK)

    Dual Terminal Batteries, Trunk Mounted Batteries & Shut-Off Switches:
    If you have a dual terminal battery, connect the main vehicle power & ground to one set of posts, and the EFI ECU main power & ground to the other set. If you have the battery installed in the trunk, you must still run the ECU main power & ground directly to the battery posts! If you need to extend the wires, use 10 gauge or larger. Solder & shrink wrap any connections. If you have a battery shut-off switch, run the switched power [ignition/electrical system, red/white switched wire & 14 AWG red system relay wire] to the ECU, on the shut-off side of the shut-off switch only. (LINK) The main power & ground must be connected directly to the battery posts. (LINK)

    ECU Mounting:
    The ECU is intended as such, that the case should NOT be ground to anything (case should not touch any metal). It should be electrically isolated from any metal. The ECU has supplied mounting hardware preinstalled, which consists of a plastic sleeve and a rubber pad installed on the sleeve. Do NOT remove this. The supplied 10-24 x 1.25" screws should be installed through the sleeves and used to mount the ECU. Nylock nuts are included. An alternate acceptable method is to remove, is to remove the existing hardware and use available ¼-20 rubber isolation dampers. These are not included. (LINK)
    Quote Originally Posted by Danny Cabral
    EFI Software Problems:
    Often times, when EFI software related functions don't work properly, it's caused by a corrupted software download/installation.
    I suggest completely removing the Holley EFI software from the "Control Panel", "My Documents" (Holley folder) and the
    "C:Drive" (Program Files, Holley folder) and install a fresh EFI software download. Save your Global File somewhere.
    ECU Firmware Problems:
    Conversely, often times, when actual ECU related functions don't work properly, it's caused by a corrupted ECU firmware installation.
    As a last resort, you can try reflashing the ECU firmware version (LINK). The ECU firmware is in with the software download (LINK).
    Also, try completely disconnecting the battery for 20 minutes. This "resets" some unusual ECU issues.
    ..........
    May God's grace bless you in the Lord Jesus Christ.

    '78 BRONCO: 508" stroker, TFS heads, 11:1 comp ratio, Dominator MPFI & DIS, cold air induction, Spal dual 12" fans/aluminum radiator, dual 3" exhaust/Magnaflow mufflers, Moroso vacuum pump, Accusump, engine oil & trans fluid coolers, 100HP progressive dry direct-port NOS, A/C, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, traction bars, 4" Skyjacker lift, 35" mud tires

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us