Results 1 to 8 of 8

Thread: Pro-Jection 4Di Not Entering Closed Loop

  1. #1

    Default Pro-Jection 4Di Not Entering Closed Loop

    Hi! I'm having problems with my Pro-Jection unit. Had it installed almost ten years ago but wasn't happy with how it ran and subsequently lost interest in the car. While this is an original Pro-Jection TB EFI unit I did get a newer EPROM and even upgraded the throttle body to use the later Delphi injectors.
    Well, finally managed to find a working laptop computer capable of running Windows XP and connected it.

    My neighbors always used to complain when I did take the car out for a short run and it actually set off the CO alarm every time. Never really understood why since the ECU should take care of that, or so I thought. Gas mileage was dire though at around 5 mpg for city driving (costly too at 6 $ a gallon).
    Last week I hooked up an exhaust gas analyzer and it turned out I was emitting 15% CO! So my idle mixture is somewhere around 10 AFR. Not good at all.

    Turned out the O2 sensor isn't doing much really:

    I don't understand what's happening here. Obviously the sensor is registering the mixture correctly, but the ECU just keeps injecting fuel without taking notice.

  2. #2


    Tried a few things today. First recalibrated the TPS by pressing the accelerator all the way down (I didn't check the .58V thing yet though). Updated the throttle angle settings:

    Didn't do much though, still no O2 correction whatsoever. A new O2 sensor is on the way, but since the original one seems to be working, I doubt it's the cause of my problems. Manually changed the fuel settings for the idle range, at least I'm guessing that's what I was trying to do (changed the MAP 60-75 settings in the 700-1000 RPM range).



    It didn't idle all that well, which I had expected since this was for testing purposes only in order to get the mixture down. For some reason the idle speed also changed even though I hadn't touched it. At first it was way too high at around 1300 RPM, later a bit low at 500-600 RPM. However the more crucial O2 voltage quickly rose back to .85-.9V. Why would it do that if I'm reducing the amount of fuel?

    Reverted back to my original fuel map to get me home, only with the updated throttle settings:

    Last edited by rory; 09-09-2017 at 08:28 PM.

  3. #3


    Ideally I'd like the O2 correction to work as intended, but if that's not possible for whatever reason I still need to lean out the mixture manually.
    Unfortunately the Pro-Jection manual isn't all that helpful here. The analogue Pro-Jection didn't use a PC interface so no description given and with the digital unit, it doesn't really cover how to create an Open Loop fuel map.

    Oh, and this would be on a Mopar 440 with three speed automatic. Stock engine, lowish compression.

    PS: Not using the spark advance feature, since this seemed even more complicated on a Mopar. While putting in a new distributor last week, I also realized it's actually connected to the same manifold vacuum source on the TB as the MAP sensor. From what I understand this isn't ideal. I'd like to keep the distributor at manifold vacuum though to get more timing at idle. Ported/timed vacuum is connected to the vacuum reservoir (brakes).
    Last edited by rory; 09-09-2017 at 07:50 PM.

  4. #4


    Actually, I was hoping for some feedback.

    Well, it's got nothing to do with the fuel pressure. Checked the supply line and it's at a more or less steady 16-17 PSI. I know the Delphi injectors are rated at 21 PSI, but I don't feel like giving them even more fuel than they're already wasting.

  5. #5


    Really, nothing?

  6. #6
    Join Date
    Dec 2009


    You'll have to contact Holley for information on this antiquated EFI system. However, don't be surprised if they're not much help either, due to how rare it is now. (Related Forum Thread)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/3000 RPM converter, FPP aluminum driveshaft, FPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 MT tires.

  7. #7


    To be honest, I remember how spectacularly unhelpful they were ten years ago when I had it installed.
    I've been thinking of fitting an Edelbrock carb instead, which is ironic really, since they're basically a 1960s design.

  8. #8

    Default TPS Adjustment

    Had another go at it and went to check my throttle position sensor settings. Instead of measuring the current (.58V @ idle position), I simply connected my laptop and opened the data monitor page. According to the manual:
    Change to the monitor screen and monitor the data as shown in the figure below. The Mode should be shown as idle. As the throttle is slowly opened, the mode should change from idle to run to full and wide open throttle. The TPS should be reading 29-31 at closed throttle conditions. If the TPS is not in this range, the user may want to adjust the TPS as outlined in section 17.3.
    Instead of 29-31 at closed throttle I got 41, aha! However, even with the TPS adjusted all the way, I couldn't get it below 38. Unscrewing the idle screw on the throttle shaft itself brought it down to 35, but that's it.

    So I took the TPS out completely and it actually read 1, which seems to indicate it's working just fine. The problem seems to be with the throttle shaft itself or with the little pickup lever which moves the TPS:

    As you can see even at closed throttle position it's not at rest (as in all the way to right). It's almost at 12 'o clock, and there's no way I can adjust the TPS that far.

    I tried to unscrew the pickup lever, but it wouldn't budge and I didn't want to damage the throttle shaft by using force. Of course there's also a screw holding on the corresponding lever on the TPS, but I didn't touch that just yet. There has to be a way to do this, please!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us