Results 1 to 6 of 6

Thread: At a loss, odd behavior.

  1. #1

    Default At a loss, odd behavior.

    Hey there folks, I was hoping to get a bit of help with some oddities I'm experiencing with my Sniper. It was running great & tuning well after setup, but a couple months down the line it randomly had a bunch of issues.

    The first issue is that it would not run the fuel pump at all while cranking or while the engine was running. It would prime, but thereafter there was no power sent to the blue wire. The second, is that some of the sensors were returning errors. The CTS gave an error reading a few times, but is currently behaving normally. The injectors simply read "error" on the Multi Gauge screen. I tried wiring the fuel pump to a switched +12V, but the engine simply isn't getting fuel. What would be a good place to start?

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    20,148

    Default

    Quote Originally Posted by George66Falcon View Post
    The first issue is that it would not run the fuel pump at all while cranking...
    When this happens, does the Sniper EFI Data Monitor display legitimate cranking RPM?

    ...or while the engine was running.
    How can the engine run with an inoperative fuel pump?

    The CTS gave an error reading a few times, but is currently behaving normally.
    I would replace the coolant temperature sensor (LINK).

    The injectors simply read "error" on the Multi Gauge screen. I tried wiring the fuel pump to a switched +12V, but the engine simply isn't getting fuel.
    Contact Holley Tech Service (LINK).
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  3. #3

    Default

    Cranking RPM shows only "stall". The pump would prime, so there would be a shot of fuel to start, but it wouldn't pump thereafter. At this point, the duty cycle reads "error" and I can't even get a 3 second start anymore.

    I'll give Holley a call when they're open Monday. Thanks for your suggestion. If you have anything else you'd recommend trying, I'd be grateful. Thanks!

  4. #4
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    20,148

    Default

    After the initial fuel pump prime time, the fuel pump won't run without a cranking RPM signal. Troubleshoot the distributor/CDI box (depending on the application).
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  5. #5

    Default

    You nailed it! I somehow broke the yellow wire going to my HEI. After repairing the connection and cycling the ignition, I no longer see "error" on the duty cycle and the car starts up! Thanks for your help.

  6. #6
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    20,148

    Default

    You're welcome, I'm glad you found the problem.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us