Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Very stiff pedal with Sniper EFI

  1. #1
    Join Date
    Oct 2016
    Location
    Middle River, MD
    Posts
    249

    Default Very stiff pedal with Sniper EFI

    It's almost as if it's sticking closed. If that's the case, then slightly cracking the butterflies open with the idle screw will skew my IAC counts. Any suggestions?

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    18,698

    Default

    May God's grace bless you in the Lord Jesus Christ.

    '78 BRONCO: 508" stroker, TFS heads, 11:1 comp ratio, Dominator MPFI & DIS, cold air induction, Spal dual 12" fans/aluminum radiator, dual 3" exhaust/Magnaflow mufflers, Moroso vacuum pump, Accusump, engine oil & trans fluid coolers, 100HP progressive dry direct-port NOS, A/C, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, traction bars, 4" Skyjacker lift, 35" mud tires

  3. #3
    Join Date
    Oct 2016
    Location
    Middle River, MD
    Posts
    249

    Default

    Thanks for the links. That should fix it if it's a leverage problem. But it feels more like it's sticking, like it would if butterflies are too far closed. I'll dig a little deeper tomorrow and confirm whether it's in fact sticking, or just need a little more leverage.

    I believe it's sticking, because there is only an issue when trying to "normally" pull away from a stop. Driving/cruising, there's no issue.

  4. #4
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    18,698

    Default

    Yes, confirm what's actually happening. You may have to disconnect the throttle cable/linkage to determine what's tight.
    May God's grace bless you in the Lord Jesus Christ.

    '78 BRONCO: 508" stroker, TFS heads, 11:1 comp ratio, Dominator MPFI & DIS, cold air induction, Spal dual 12" fans/aluminum radiator, dual 3" exhaust/Magnaflow mufflers, Moroso vacuum pump, Accusump, engine oil & trans fluid coolers, 100HP progressive dry direct-port NOS, A/C, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, traction bars, 4" Skyjacker lift, 35" mud tires

  5. #5
    Join Date
    Oct 2016
    Location
    Middle River, MD
    Posts
    249

    Default

    Well, it isn't the blades binding in their bores, so it has to be a leverage problem. Guess I'll be either ordering, or making an extended arm. Thanks.

  6. #6
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    18,698

    Default

    You're welcome. It's actually fairly common, and it's been mentioned on this forum before. Especially with overdrive transmissions with TV (throttle valve) cables.
    May God's grace bless you in the Lord Jesus Christ.

    '78 BRONCO: 508" stroker, TFS heads, 11:1 comp ratio, Dominator MPFI & DIS, cold air induction, Spal dual 12" fans/aluminum radiator, dual 3" exhaust/Magnaflow mufflers, Moroso vacuum pump, Accusump, engine oil & trans fluid coolers, 100HP progressive dry direct-port NOS, A/C, LenTech Strip Terminator wide-ratio AOD/2500 RPM converter, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, traction bars, 4" Skyjacker lift, 35" mud tires

  7. #7
    Join Date
    Oct 2016
    Location
    Middle River, MD
    Posts
    249

    Default

    Mine's just the cable operated throttle. Turbo 400, so no kickdown. Thanks again.

  8. #8

    Default

    I'm having the same issue. I made a bracket but no matter how I modify it, I never get full travel. In this picture I get 93% open and the cable is extended to its limit. Does anybody have a picture of the Holley 20-14 installed?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1489.jpg 
Views:	235 
Size:	100.1 KB 
ID:	2270  

  9. #9

    Default

    The mounting for the cables "mount" (not the ends of the cable) is too close for the cable you have. Google Edelbrock #8030 or #8036 then click on "Google Images" to see how it's mounted.

  10. #10

    Default

    I'm probably going to have to get an aftermarket throttle cable. If I use the Edelbrock ones you sent, the cable end won't have enough extension to reach the stud. Mine now has a plastic piece over the smaller plastic, and it will cause interference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us