Results 1 to 3 of 3

Thread: Dominator Bump Setup

  1. #1

    Default Dominator Bump Setup

    I'm sure this is played out, but I've read like a million threads, and have no idea what is going on with my specific setup. I have the Holley solid state relay. The bump button is ran to the input as 20V, the transbrake is run like it was before I added the bump as far as inputs. I have the Output to the Holley SSR as PWM-, and I can hear the relay for the transbrake activating on my board, but it will not send power to the transbrake. If I remove the SSR, the transbrake I HAVE USED ALL THE SAME SETTING THEY HAVE POSTED ON THE E Works normal. I really don't want to have to buy an aftermarket box. I used all the settings and the diagram from: https://www.facebook.com/holleyefitutor/?fref=ts

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,728

    Default

    Depending on the bump box control type, you'll need 2 Inputs & 3 Outputs, or 2 Inputs & 1 Outputs.
    http://forums.holley.com/showthread....0899#post60899 (3 Relay vs 1 Relay Bump Box Versions)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: 385" SBF, Dart SHP 8.2 block, TFS TW 11R 205 heads, 11.8:1 comp, TFS R-Series intake, Dominator MPFI & DIS, 36-1 crank trigger/1x cam sync, 160A 3G alternator, Optima Red battery, A/C, 100HP progressive dry direct-port NOS, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/off-road X-pipe/shorty headers, S&W subframe connectors, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, M4602G aluminum driveshaft, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  3. #3
    Join Date
    Nov 2013
    Location
    Chicago IL
    Posts
    1,952

    Default

    Quote Originally Posted by ghost-1 View Post
    I'm sure this is played out, but I've read like a million threads, and have no idea what is going on with my specific setup. I have the Holley solid state relay. The bump button is ran to the input as 20V, the transbrake is run like it was before I added the bump as far as inputs. I have the Output to the Holley SSR as PWM-, and I can hear the relay for the transbrake activating on my board, but it will not send power to the transbrake. If I remove the SSR, the transbrake I HAVE USED ALL THE SAME SETTING THEY HAVE POSTED ON THE E Works normal. I really don't want to have to buy an aftermarket box. I used all the settings and the diagram from: https://www.facebook.com/holleyefitutor/?fref=ts
    TRY DIFFERENT SETTINGS. There's no magical number that works on all transbrake solenoids. You just have to experiment until you get it to work. Sometimes you have to start with a very low frequency to find out what your solenoid can actually do.
    -Scott
    Don't forget to check out progress on my Race Car:
    Project Blasphemy - 8.07 @ 171
    Low 8 Second Street Car

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us