Hi guys. A customer of mine installed their own Avenger EFI with TBI on a small block Chevy. All was good until they tried the initial setup procedure, which is when I got the call after they had no joy. When you use the handheld screen to set the camshaft, engine size, etc., once ignition is switched on, it displays "connecting" and from there it's supposed to display "HEFI connected". But instead it displays "connect HEFI", and that's about as far as it goes. You can use the little joy stick to scroll down and it will display "Wizard" etc. You go through the menus, cam, engine, distributor etc, go to load up the profile and it then displays "empty" as if there's no file to load. Tried the 2nd hand piece that came with the ECU but no change, and the screen was very dull compared to the 1st. Checked all voltages and connections, and all are by the book. It's as if there's no communication between the ECU and the hand piece. Could the ECU have no program or have lost its programming? Should we plug in a laptop and download the latest file and install it? Tried calling Holley yesterday, but being in New Zealand, sitting on hold forever does not impress nor help the phone bill. Any help would be appreciated. Cheers, Chris.