Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Injectors Not Firing

  1. #1

    Default Injectors Not Firing

    I'm running the Holley Dominator EFI on an LS based engine. The car was previously running, but I had to pull the engine to do some repairs. I put the engine in this morning, and hooked everything up as I did previously. I'm getting spark, but injectors are not firing.

  2. #2
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,104

    Default

    http://forums.holley.com/showthread....5760#post45760 (Scroll Down To "Typical No-Start Checks".)
    http://forums.holley.com/showthread....9799#post79799 (Related Forum Thread - RPM Errors & System Logs)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  3. #3

    Default

    I posted a few days ago about a no start condition. I'm running the LS1 kit on the Dominator ECU that was previously running. I pulled the engine to do repairs, and just finished putting it back in over the weekend. I have +12 volt power to the injectors, so I'm assuming they're not getting the ground pulse signal. I ran a System Log and saw that the crank & cam sensors are working. I've been on the phone with Holley Tech for two days now, and still can't figure it out. I emailed my System Log to them as well.

  4. #4
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,104

    Default

    Is the battery fully charged? Have you performed a TPS Autoset? Does the Data Monitor display legitimate cranking RPM? Incorrect crank/cam sensor air gap? Improper Engine & Ignition Parameters?
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  5. #5

    Default

    RPM seems to be accurate. Misunderstood the sensor question; the air gap is not adjustable on the LSx sensors.

  6. #6
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,104

    Default

    Quote Originally Posted by Lmt0705 View Post
    Misunderstood the sensor question; the air gap is not adjustable on the LSx sensors.
    I know it's not adjustable, but is the sensor air gap correct? On this forum, it's been an LSx problem a few times.
    http://forums.holley.com/showthread....1368#post71368 (Here's one LSx example.)

    RPM seems to be accurate.
    Please answer the two other questions from post #4.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  7. #7

    Default

    Battery is fine. Did the TPS Autoset. RPM seems legit, hovering in the low 100s when cranking. I had another known good sensor that I swapped it with the other day. This was a running/driving car for several months, before I pulled the engine. Driving me insane! LOL. I disabled the cam sensor so injectors would batch fire, nothing. Put direct power to the +12V triggered wire, nothing. Running out of ideas.

  8. #8
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,104

    Default

    Quote Originally Posted by Lmt0705 View Post
    The car was previously running, but I had to pull the engine to do some repairs.
    Just out of curiosity, what engine repairs were performed?

    I have +12 volt power to the injectors, so I'm assuming they're not getting the ground pulse signal.
    It would be helpful if you would verify this.
    http://forums.holley.com/showthread....9623#post69623 (System Relay/Fuel Injector Troubleshooting)
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

  9. #9

    Default

    I took my computer to a friend who runs it also; loaded his tune and it fired right up. It's the same program I ran for several months. Can a file become corrupted?

  10. #10
    Join Date
    Dec 2009
    Location
    Connecticut
    Posts
    22,104

    Default

    Quote Originally Posted by Lmt0705 View Post
    It's the same program I ran for several months.
    Evidently not, because it doesn't run. Something changed.

    Can a file become corrupted?
    Not unless you updated something, or there was an electrical problem.
    May God's grace bless you in the Lord Jesus Christ.
    '92 Ford Mustang GT: Dominator MPFI & DIS, A/C, Spal dual 12" fans/3-core Frostbite aluminum radiator, Pypes dual 2.5" exhaust/X-pipe/shorty headers, 100HP progressive dry direct-port NOS, 160A 3G alternator, Optima Red battery, LenTech Strip Terminator wide-ratio AOD/2800 RPM converter, FRPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 tires.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Holley has been the undisputed leader in fuel systems for over 100 years. Holley carburetors have powered every NASCAR® Sprint® Cup team and nearly every NHRA® Pro–Stock champion for four decades. Now, Holley EFI is dominating the performance world as well as our products for GM's LS engine. Holley's products also include performance fuel pumps, intake manifolds & engine dress–up products for street performance, race and marine applications. As a single solution, or partnered with products from other Holley companies - Hooker Headers, Flowtech Headers, NOS Nitrous, Weiand, Earl's Performance Plumbing, or Diablosport - Holley products can give you the edge you need over the competition.
Join us