Announcement

Collapse
No announcement yet.

Two Step with Pro Mag 12LT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Two Step with Pro Mag 12LT

    Im having a issue with my Pro Mag when using a two step and hopeful that someone may be able to assist.

    Parts are a 12LT, #8106 Points box, #8739 2 step, and a #8132 converter.

    Drag race application, Car does carry a 12v optima battery.

    When on the two step, no matter what chip is used the tach will read roughly 600 RPM less than the selected chip...and this is for every chip I have. I have ohm'd the chips and they are good. The tach is a Auto Meter playback style and live or when looking at a recording the rpm is less When the car shifts at selected RPM, the tach is dead on with what I have in the shift. I have also checked the tach with another unit with the same results.

    It leaves me with questions is the tach losing signal and just reading wrong...meaning that im really leaving at desired RPM or is there more going on here and its actually leaving at the 600 rpm less than selected?

  • #2
    yes, it will lose signal.... a mag works totally different on the rev-limiter then the cd ignitions .

    Comment


    • #3
      Originally posted by msdtech1955 View Post
      yes, it will lose signal.... a mag works totally different on the rev-limiter then the cd ignitions .
      With that in mind, is the two step working at the correct rpm that I have selected or is there a chance that it is actually at the lower RPM as I described.

      Thanks for the quick reply.

      Comment

      Working...
      X