Announcement

Collapse
No announcement yet.

Stumble after fitting new heads & cam.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stumble after fitting new heads & cam.

    I have a Commander 950 throttle body system on a 440 Chrysler that has worked well for the last 15+ years. I have recently fitted a pair of Edelbrock heads and a very mild roller cam with all the associated valve gear and followers.

    I knew it would need some retuning, but I'm struggling to fix a stumble. I can drive it down the highway and accelerate hard with no trouble, but if I accelerate gently it'll stumble at about 1500 RPM. No amount of extra fuel or taking fuel out seems to fix it.

    The wideband O2 sensor numbers are OK, but when it stumbles it goes lean and no amount of extra fuel seems to fix it, today I doubled the numbers in the area of stumble and it made no difference so I removed fuel and them it started hesitating as I cruise. I've tried more & less Acceleration Enrichment with no change.

    The spark plugs are less than 500 miles old. I'm using a crank trigger with an MSD Blaster coil and there's no detonation. The distributor is phased correctly. The fuel pressure is set to 24 psi and when monitored only fluctuates 1 or 2 psi even at full throttle.

    What am I missing? I've tuned numerous Commander 950 systems with no trouble, but this has got me puzzled. Anything I can try? Thanks.

    UPDATE: Over the last few days, I've checked everything, replaced several ignition components just in case, and no improvement.

    I've fitted a new WBO2 sensor in case it was giving wrong numbers. I've checked the fuel pressure and fitted another MAP sensor.

    Nothing I seem to do or change on the numbers seems to have any impact on this stumble. As I pull away the stumble happens, more or less throttle will stop it, but it happens each time I go through the 1500 to 1800 rev range on gentle acceleration.

    Has anyone had this before? Unless I can come up with a fix, I feel the only other option is a rolling road. Thanks

  • #2
    Today's update: I've tried everything at least twice, so out of desperation I switched off the WBO2 sensor and tried it. All the hesitation and stumbling stopped. I switched it back on and it started again.

    The readout shows that nothing is wrong with the settings, but the WBO2 sensor seems to having an affect. The WBO2 sensor is only a couple of months old and has less than 1500 miles on it.

    Comment


    • #3
      That means the Target Air/Fuel Ratio table is wrong for your engine or there's an exhaust leak upstream of the WBO2 sensor.
      May God's grace bless you in the Lord Jesus Christ.
      '92 Ford Mustang GT: 385"/6.3L SBF, Dart SHP 8.2 block, forged steel crankshaft & H-beam rods, forged pistons, Trick Flow Twisted Wedge 11R 205 CNC Comp Ported heads, 12:1 compression ratio, 232-244 duration/.623" lift/114 LSA camshaft, TFS R-Series FTI Comp Ported intake, BBK 80mm throttle body, Holley Dominator MPFI & DIS, Holley 36-1 crank trigger, MSD 1x cam sync, PA PMGR starter, PA 200A 3G alternator, Optima 34/78 Red battery, 100HP progressive dry direct-port NOS, R134a A/C, Spal Dual 12" HP 3168 CFM fans, Frostbite 3-core aluminum radiator, Pypes dual 2.5" exhaust, off-road X-pipe, shorty headers, Earl's -6AN fuel system plumbing, Walbro 255 LPH in-tank pump & Pro-M -6AN hanger, S&W subframe connectors, BMR upper & lower torque box reinforcements, LenTech Strip Terminator wide-ratio AOD, 3000 RPM C6 converter, B&M Hammer shifter, Stifflers transmission crossmember & driveshaft safety loop, FPP aluminum driveshaft, FPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 M/T Street Comp tires.

      Comment


      • #4
        Thanks Danny, the Target Air/Fuel Ratios are 14.7 for cruise, 12.6 for hard acceleration, and 13.0 for part throttle. Do you think I need more fuel? There are no exhaust leaks.

        Comment


        • #5
          Look at the Data Monitor and see what the AFR is, since the engine seems to like it.
          May God's grace bless you in the Lord Jesus Christ.
          '92 Ford Mustang GT: 385"/6.3L SBF, Dart SHP 8.2 block, forged steel crankshaft & H-beam rods, forged pistons, Trick Flow Twisted Wedge 11R 205 CNC Comp Ported heads, 12:1 compression ratio, 232-244 duration/.623" lift/114 LSA camshaft, TFS R-Series FTI Comp Ported intake, BBK 80mm throttle body, Holley Dominator MPFI & DIS, Holley 36-1 crank trigger, MSD 1x cam sync, PA PMGR starter, PA 200A 3G alternator, Optima 34/78 Red battery, 100HP progressive dry direct-port NOS, R134a A/C, Spal Dual 12" HP 3168 CFM fans, Frostbite 3-core aluminum radiator, Pypes dual 2.5" exhaust, off-road X-pipe, shorty headers, Earl's -6AN fuel system plumbing, Walbro 255 LPH in-tank pump & Pro-M -6AN hanger, S&W subframe connectors, BMR upper & lower torque box reinforcements, LenTech Strip Terminator wide-ratio AOD, 3000 RPM C6 converter, B&M Hammer shifter, Stifflers transmission crossmember & driveshaft safety loop, FPP aluminum driveshaft, FPP 3.31 gears, Cobra Trac-Lok differential, Moser 31 spline axles, '04 Cobra 4-disc brakes, '93 Cobra booster & M/C, 5-lug Bullitt wheels & 245/45R17 M/T Street Comp tires.

          Comment

          Working...
          X