No announcement yet.

MSD Atomic with 80K miles failed trying to diagnose.

  • Filter
  • Time
  • Show
Clear All
new posts

  • tcm308
    So there's no RPM signal while cranking? I'd confirm the TPS isn't stuck high which would activate Clear Flood mode.

    Leave a comment:

  • MSD Atomic with 80K miles failed trying to diagnose.

    MSD Atomic has around 80K miles on it. Timing control enabled. Shut vehicle off and will not start. MSD 6AL 6201 is good, checked MSD 85561 distributor and is good, Coil MSD Master Blaster 2 is good. System is setup with computer controlled timing with yellow wire from Atomic connected to white of 6AL, no ignition spark condition and of course no injector pulses. Changed wire configuration to non-timing control, it has spark and will run for a few seconds, (from ignition ON fuel pulse) until engine burns that fuel. There's no fuel added from injectors after start, trigger impulse is not being recognized by ECU, is my assumption. No error codes, only system error that's showing is WBO2 error. MSD distributor hooked directly to 6AL, spark works perfectly. Tried spare MSD 85561 distributor and spare MSD 6AL with new harness and spare coil same results. Triggering with computer control configuration results in no spark and no start. Non-timing controlled configuration produces ignition spark, but doesn't trigger any injector pulse after initial prime pulses, engine starts burns fuel & dies. Also MSD EFI power unit tried on different vehicle and worked fine. Checked resistance of all wires between TBI and 6AL and between distributor and 6AL all check good. Any input would be appreciated. I suspect failure of ECU. Thanks.